summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-19 07:58:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-19 09:22:19 +0200
commit8ca1e572288b6490da6b9182201be1ab64d4bd22 (patch)
treec9aa082a286404e4c36429f6d6261be264285623 /dev-python/debugpy
parentdev-python/authheaders: Bump to 0.14.1 (diff)
downloadgentoo-8ca1e572288b6490da6b9182201be1ab64d4bd22.tar.gz
gentoo-8ca1e572288b6490da6b9182201be1ab64d4bd22.tar.bz2
gentoo-8ca1e572288b6490da6b9182201be1ab64d4bd22.zip
dev-python/debugpy: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debugpy')
-rw-r--r--dev-python/debugpy/Manifest1
-rw-r--r--dev-python/debugpy/debugpy-1.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/debugpy/Manifest b/dev-python/debugpy/Manifest
index d9567ae5c0a3..9a401da63608 100644
--- a/dev-python/debugpy/Manifest
+++ b/dev-python/debugpy/Manifest
@@ -1 +1,2 @@
DIST debugpy-1.5.0.gh.tar.gz 6676475 BLAKE2B a8aa0afe7b76beb6ba539e23558d6a0c8babfd55de9a4a0bc9aabbec8a2318e600df62b063a8d674d9402e35fd595b030efca570b4a67ec82dadb98875261e13 SHA512 b5ca216aede744a9b1e067056601470e78b8af1fabb181dc0bf6e87bc166cc8d6cad24f5695986686cac69f8ce41246bb0f074078ef3750f6e65b4d8fe55e869
+DIST debugpy-1.5.1.gh.tar.gz 6675322 BLAKE2B a8e3a07d5dbd1b5ca39301e703b279514653606f98743a396693738c9a89403c73a6b6942e5dc368dd89eb8b74277e1808f9247573f330e3a94596c26af7e5be SHA512 93ee526ca7cb3d44b85106a33d8f930f4f2b307eb26ede3ab6b5653de986a101b10f545f5de12cd8ee6ff9e9a12c5e4b57c4c40b1b3003c2f555676bd34482ce
diff --git a/dev-python/debugpy/debugpy-1.5.1.ebuild b/dev-python/debugpy/debugpy-1.5.1.ebuild
new file mode 100644
index 000000000000..cbb6127cca56
--- /dev/null
+++ b/dev-python/debugpy/debugpy-1.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
+HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
+SRC_URI="
+ https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# There is not enough time in the universe for this test suite
+RESTRICT="test"
+
+RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.2-unbundle-pydevd.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Drop unnecessary and unrecognized option
+ # __main__.py: error: unrecognized arguments: -n8
+ # Do not timeout
+ sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die
+
+ # Unbundle dev-python/pydevd
+ rm -r src/debugpy/_vendored || die
+
+ distutils-r1_python_prepare_all
+}