summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-31 02:34:05 +0000
committerSam James <sam@gentoo.org>2023-10-31 02:34:42 +0000
commit08a1a475952802444c633894fc7101051c0ae6d7 (patch)
treee85a20d778f306c6d23685d2f30392f184bf26ba /dev-python/contourpy
parentapp-containers/buildah: add containers-common as RDEPEND (diff)
downloadgentoo-08a1a475952802444c633894fc7101051c0ae6d7.tar.gz
gentoo-08a1a475952802444c633894fc7101051c0ae6d7.tar.bz2
gentoo-08a1a475952802444c633894fc7101051c0ae6d7.zip
dev-python/contourpy: use DISTUTILS_ARGS for werror instead
Eli rightly pointed out we could do this. Followup to 08b40d01e9705226bcf7eb7fbe577ba2359d63f9. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/contourpy-1.1.1.ebuild4
-rw-r--r--dev-python/contourpy/files/contourpy-1.1.1-no-werror.patch11
2 files changed, 2 insertions, 13 deletions
diff --git a/dev-python/contourpy/contourpy-1.1.1.ebuild b/dev-python/contourpy/contourpy-1.1.1.ebuild
index 4f2ad18a7011..a568f5a7c374 100644
--- a/dev-python/contourpy/contourpy-1.1.1.ebuild
+++ b/dev-python/contourpy/contourpy-1.1.1.ebuild
@@ -35,8 +35,8 @@ BDEPEND="
)
"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1.1-no-werror.patch
+DISTUTILS_ARGS=(
+ -Dwerror=false
)
distutils_enable_tests pytest
diff --git a/dev-python/contourpy/files/contourpy-1.1.1-no-werror.patch b/dev-python/contourpy/files/contourpy-1.1.1-no-werror.patch
deleted file mode 100644
index 4db618369434..000000000000
--- a/dev-python/contourpy/files/contourpy-1.1.1-no-werror.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-XXX: We should really just make meson-python in distutils-r1 always disable werror.
---- a/meson.build
-+++ b/meson.build
-@@ -4,7 +4,6 @@ project(
- default_options: [
- # meson-python options are set in pyproject.toml
- 'cpp_std=c++17',
-- 'werror=true',
- ],
- license: 'BSD-3-Clause',
- meson_version: '>= 1.2.0',