summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/colorama
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/Manifest2
-rw-r--r--dev-python/colorama/colorama-0.3.2.ebuild22
-rw-r--r--dev-python/colorama/colorama-0.3.3.ebuild22
-rw-r--r--dev-python/colorama/metadata.xml17
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/colorama/Manifest b/dev-python/colorama/Manifest
new file mode 100644
index 000000000000..c5477999c938
--- /dev/null
+++ b/dev-python/colorama/Manifest
@@ -0,0 +1,2 @@
+DIST colorama-0.3.2.tar.gz 18343 SHA256 218862857d74ff781c2caf44629a7d72b88bbb8a2b0aa0f4f1eb8666f8305c11 SHA512 1fe6d72a4f56ef1adb96f70b1721223937647a2f22648bececf7ad05710d82bede767ebd00e9267db0f874ddbe3ec852b82408794b80ea803c888dcfcd9b9532 WHIRLPOOL b49b276772798ba0b606f0b109d8eef1aaeaa6103e143765f75c3c9275b5e94a06aefd05856e0534372fcf0e3da10b236eac8f1f0b4962ec297beff0cfafe059
+DIST colorama-0.3.3.tar.gz 22765 SHA256 eb21f2ba718fbf357afdfdf6f641ab393901c7ca8d9f37edd0bee4806ffa269c SHA512 8e6177ea60ab8f1267ce982f23803a9d2eb0c4550d7eac4776416d62a99d1ce03254fc64cc959ca95e2409ceeff081d4d19359c383e969dfb921b44c56914495 WHIRLPOOL e5fe6c0046b558abdde260d9d89e3cbe197165f99fb4f7134c14fff95e6c1e92b3472a95001d847ab58e8445c87f21774a71f629771593934ea070838c765461
diff --git a/dev-python/colorama/colorama-0.3.2.ebuild b/dev-python/colorama/colorama-0.3.2.ebuild
new file mode 100644
index 000000000000..671172f1e82d
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Makes ANSI escape character sequences for producing colored terminal text & cursor positioning"
+HOMEPAGE="http://code.google.com/p/colorama/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/colorama/colorama-0.3.3.ebuild b/dev-python/colorama/colorama-0.3.3.ebuild
new file mode 100644
index 000000000000..a89ee41317e5
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Makes ANSI escape character sequences for producing colored terminal text & cursor positioning"
+HOMEPAGE="http://code.google.com/p/colorama/ https://pypi.python.org/pypi/colorama https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/colorama/metadata.xml b/dev-python/colorama/metadata.xml
new file mode 100644
index 000000000000..6d2cc60852ec
--- /dev/null
+++ b/dev-python/colorama/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Makes ANSI escape character sequences, for producing colored terminal text
+ and cursor positioning, works under MS Windows.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">colorama</remote-id>
+ <remote-id type="github">tartley/colorama</remote-id>
+ </upstream>
+</pkgmetadata>