summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 15:09:47 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 15:09:47 +0200
commit3969820aec335373641d295ade33bb4b03f7c520 (patch)
tree1ea82535f7d33c0241b37f9c1aab13ab8f69e430 /dev-python/cli_helpers
parentdev-python/cli_helpers: Bump to 1.2.1, add tests (diff)
downloadgentoo-3969820aec335373641d295ade33bb4b03f7c520.tar.gz
gentoo-3969820aec335373641d295ade33bb4b03f7c520.tar.bz2
gentoo-3969820aec335373641d295ade33bb4b03f7c520.zip
dev-python/cli_helpers: Sync the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/cli_helpers-9999.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-9999.ebuild b/dev-python/cli_helpers/cli_helpers-9999.ebuild
index a781b76eb170..edaf342667d6 100644
--- a/dev-python/cli_helpers/cli_helpers-9999.ebuild
+++ b/dev-python/cli_helpers/cli_helpers-9999.ebuild
@@ -1,24 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
inherit distutils-r1 git-r3
DESCRIPTION="Python helpers for common CLI tasks"
-
HOMEPAGE="http://cli-helpers.rtfd.io/"
SRC_URI=""
+
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
RDEPEND="
- >=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-csv-1.0[${PYTHON_USEDEP}]' -2)
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
>=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}