summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-06 06:35:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-06 06:44:02 +0200
commit25d11bdd7077eb10244df693c7dd27fbada25dbe (patch)
tree75e799b1cc41595c941abd8e005454d21d46e545 /dev-python/cfn-lint
parentdev-python/simsimd: Bump to 5.0.0 (diff)
downloadgentoo-25d11bdd7077eb10244df693c7dd27fbada25dbe.tar.gz
gentoo-25d11bdd7077eb10244df693c7dd27fbada25dbe.tar.bz2
gentoo-25d11bdd7077eb10244df693c7dd27fbada25dbe.zip
dev-python/cfn-lint: Bump to 1.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.9.5.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 0c936e4d4fea..0105465e9bfb 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.8.2.tar.gz 2377269 BLAKE2B 8f4266c6d90f50f614f203a4b34ffc15397c973e8af07510c64e21bd80f1c4dd0f5bf6283268cbc69fbe505d6c945cc058ec0f06b05e868b3149941ab28b3948 SHA512 2605c5880960e3bce2822f2d9b9bd221d4ab7d77a4d9a1bcbdbf6df8f50492877daf704f84157946519a9da96f9d3de5ed5e65629d259726a10e1fb38c963950
DIST cfn_lint-1.9.3.tar.gz 2562556 BLAKE2B c8816021cfb83e2c0d915cc58e7c099bf8ff0640b0562ddf3a7bcfca250e7d4fa03480ff99b5eef4fb103a77aca9a2b3c5266a30b19cddc899f7c0ccb3ca88d6 SHA512 fd75a60b7249bb3f0865d4a37b70d5f64012879b332dfe240f7d7eddc5ae48674e7372b959dd6964f8d0c028c0b75dc78c25caf0ebb3e5186bb6b2b7004e1212
DIST cfn_lint-1.9.4.tar.gz 2563835 BLAKE2B 50694ee3982cda4e6df6aa2e8be2c0ae3182899947897d71764426f7fa14225ce44248af42e3d74e1b0159f216a02bc41f6675ab04dd09210bc66419913a5fdb SHA512 345d3aaa1dc6dfa1049061b4563c0f705510e69058e2184e7220f3dba776522967115a273e5044032a02b96c985a71acd4c1c31f7a71d819309d74dd60242456
+DIST cfn_lint-1.9.5.tar.gz 2457425 BLAKE2B 37a065cc7e0462feae7d4fc0b599bf9e2c96a88010690d1440de0f45c829d75c4df98eb7513e3a4992bd7769795351e5022f23925aae84f262183afb474fb59d SHA512 b793271a4b0d5febc4eb1f4411daf5ba3e17cb864ce63e143963c55becc3dbd11617eae8e66c4299f906c1ac4aadf8361c9082e6dd5e1fa11663ddad09f1618a
diff --git a/dev-python/cfn-lint/cfn-lint-1.9.5.ebuild b/dev-python/cfn-lint/cfn-lint-1.9.5.ebuild
new file mode 100644
index 000000000000..4ec420c8b216
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.9.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.89.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}