summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 21:02:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 21:02:42 +0100
commit71f6ac45fbebc5efaa00c25b543e34a67f011d82 (patch)
tree75db89222f96444229e85e7cd692eb7326d9a7b0 /dev-python/catkin_pkg
parentapp-office/libreoffice-bin: Drop 6.4.7.2_p1 (diff)
downloadgentoo-71f6ac45fbebc5efaa00c25b543e34a67f011d82.tar.gz
gentoo-71f6ac45fbebc5efaa00c25b543e34a67f011d82.tar.bz2
gentoo-71f6ac45fbebc5efaa00c25b543e34a67f011d82.zip
dev-python/catkin_pkg: generate setup.py without newline in description
Closes: https://bugs.gentoo.org/765868 Closes: https://bugs.gentoo.org/765877 Closes: https://bugs.gentoo.org/765772 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild (renamed from dev-python/catkin_pkg/catkin_pkg-0.4.23.ebuild)3
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild3
-rw-r--r--dev-python/catkin_pkg/files/summary_single_line.patch19
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.23.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
index 677f0b8d9890..22de5978719b 100644
--- a/dev-python/catkin_pkg/catkin_pkg-0.4.23.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -50,6 +50,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix2.patch"
"${FILESDIR}/ros_packages.patch"
"${FILESDIR}/infinite_loop4.patch"
+ "${FILESDIR}/summary_single_line.patch"
)
python_test() {
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 677f0b8d9890..22de5978719b 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -50,6 +50,7 @@ PATCHES=(
"${FILESDIR}/catkin_prefix2.patch"
"${FILESDIR}/ros_packages.patch"
"${FILESDIR}/infinite_loop4.patch"
+ "${FILESDIR}/summary_single_line.patch"
)
python_test() {
diff --git a/dev-python/catkin_pkg/files/summary_single_line.patch b/dev-python/catkin_pkg/files/summary_single_line.patch
new file mode 100644
index 000000000000..d24c284da9ea
--- /dev/null
+++ b/dev-python/catkin_pkg/files/summary_single_line.patch
@@ -0,0 +1,19 @@
+setuptools will disallow newlines in descriptions, so do not generate them
+see e.g. https://bugs.gentoo.org/765868
+
+Index: catkin_pkg-0.4.23/src/catkin_pkg/python_setup.py
+===================================================================
+--- catkin_pkg-0.4.23.orig/src/catkin_pkg/python_setup.py
++++ catkin_pkg-0.4.23/src/catkin_pkg/python_setup.py
+@@ -99,9 +99,9 @@ def generate_distutils_setup(package_xml
+ data['url'] = package.urls[0].url
+
+ if len(package.description) <= 200:
+- data['description'] = package.description
++ data['description'] = package.description.replace('\n', ' ')
+ else:
+- data['description'] = package.description[:197] + '...'
++ data['description'] = package.description[:197].replace('\n', ' ') + '...'
+ data['long_description'] = package.description
+
+ data['license'] = ', '.join(package.licenses)