summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-18 08:00:10 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-18 08:35:54 +0100
commitc68676ad28429b9c62da9c6e594a3e819f7163ef (patch)
treea40fc32aef487301b09c0ae78622a2f1406b3507 /dev-python/boto3
parentdev-python/botocore: Bump to 1.36.22 (diff)
downloadgentoo-c68676ad28429b9c62da9c6e594a3e819f7163ef.tar.gz
gentoo-c68676ad28429b9c62da9c6e594a3e819f7163ef.tar.bz2
gentoo-c68676ad28429b9c62da9c6e594a3e819f7163ef.zip
dev-python/boto3: Bump to 1.36.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.36.22.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index d846cd239b9d..205650b9f3fd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.36.11.gh.tar.gz 896841 BLAKE2B 092cfaeb6dc6f6d3f523fe4e0b600817e6145a224c2b43b6dd47376d6aa1a586bf3784b2960f4179b271128d20c3edd5b435cabd6e3ddc2330f0b0ad5ce306d9 SHA512 6f17d0b6f67ace0485fbc2d809f013fddd4cf1211eb6c9a1fe0ed7c0bc117aedc9e4b7db4d4570818907db6344b19331d8a7b6246928ed5c5e294b9b5a9504dc
DIST boto3-1.36.16.gh.tar.gz 898785 BLAKE2B fa3de504bb8c58fa5653a3fc3414a333283c04ca800b8d37b310b291e60af96b27c994d2571e4dc0f159c98a41d014000ce7afe020f38da80a2cac49283ba2cc SHA512 6cbbe6cdb505ace41e5e20ff144d1d312d8a53e3c7c2e8d50a981c55e485cdf98ac6711c36cb3697e257aab08e240fa1e731485aec3dd8b74cd5163c489bd61f
DIST boto3-1.36.21.gh.tar.gz 901823 BLAKE2B 9659b8f05c90deeeeedc19f8c1bbd777415b778cf33f0ff2945063e64d413da9365f1a7e0dfc6ee159c00785299eece92596ae38d8a5d2bba02fe344ed2a052c SHA512 f13d44519aa9d62ca26cd7731b7b83cb67bc85d649a3fd61756048a5fe9254d4a1af8fae55b546fce692ca35becf5bfea2c25bde2a63c8c8783b064a61814da7
+DIST boto3-1.36.22.gh.tar.gz 902280 BLAKE2B 14633c089bad39b5b487ebdb8cc9cce9424980100d5b0617f7481f2b1cf6c3777758085960f170d7c558442d69b76dbb92b64ea5fcdc9fb8e62a405faf8f0b7c SHA512 e326011c093128abde17dd68f7fdaa455dcb366d20e6fc470347787c1eaf0f7110be39546201dee81d8fe734e7d836855a4ab5350c4fa7f6361147571444f062
diff --git a/dev-python/boto3/boto3-1.36.22.ebuild b/dev-python/boto3/boto3-1.36.22.ebuild
new file mode 100644
index 000000000000..b087a88814e8
--- /dev/null
+++ b/dev-python/boto3/boto3-1.36.22.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}