summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-26 06:19:54 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-26 07:03:10 +0100
commit6349b576eb58bcecb8b0451e896d2df1cdfe165f (patch)
tree806ccc6fce67a4a68f4ac35c60cab9a433f49a63 /dev-python/boto3
parentdev-python/botocore: Bump to 1.37.1 (diff)
downloadgentoo-6349b576eb58bcecb8b0451e896d2df1cdfe165f.tar.gz
gentoo-6349b576eb58bcecb8b0451e896d2df1cdfe165f.tar.bz2
gentoo-6349b576eb58bcecb8b0451e896d2df1cdfe165f.zip
dev-python/boto3: Bump to 1.37.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.37.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a6425c5cdfe7..db262756b95d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.36.16.gh.tar.gz 898785 BLAKE2B fa3de504bb8c58fa5653a3fc3414a333283c
DIST boto3-1.36.21.gh.tar.gz 901823 BLAKE2B 9659b8f05c90deeeeedc19f8c1bbd777415b778cf33f0ff2945063e64d413da9365f1a7e0dfc6ee159c00785299eece92596ae38d8a5d2bba02fe344ed2a052c SHA512 f13d44519aa9d62ca26cd7731b7b83cb67bc85d649a3fd61756048a5fe9254d4a1af8fae55b546fce692ca35becf5bfea2c25bde2a63c8c8783b064a61814da7
DIST boto3-1.36.26.gh.tar.gz 903988 BLAKE2B f9bb945e9132a7af7bd92ff48e5a99cc89488283c30e2d7d0cbb22d9002bd41c5d5f8a449494d2aa4758648aca3c2e88dad8bebda640af4bba7df64e72ffd2bc SHA512 77a545fd94ed50114db72d7b763e232356e78cda7a2780c12c26b602ed85101218339adf6247ba45e3a8b16c33fb11f5fb34572a37dfeac43dd9322823372cc1
DIST boto3-1.37.0.gh.tar.gz 905790 BLAKE2B 8748fb2d4a121fc2c363e1eec7b2f5659b95b3729aaa12986d4991245fe225ab2215de3877b787ad917f9cc143998f8386e4091269dfd83fb1345345bb82f637 SHA512 33efb9eca9750fda5323170ce5dd5f3368215a9046f616490bc5397ee159bbb4999502ce83176d4d1429c22c119e657357e70af3e8400b5bbbeedc6a30fdf98d
+DIST boto3-1.37.1.gh.tar.gz 906424 BLAKE2B 007da322565a7527a1b69c5960a7193e61eb0ce6efd76f3d7c74a3d859363e8be87fb8392e2c18803b8dab096deb42fefa611996f1ecc68c624bb3fefbf52e84 SHA512 b57b0ba09bae819ff3d4df721d5fcf89bb7f6cfcfd08d9012e468663941b7d6ea1f6d9f05970db6bc847935a85a72c511402c017a70a8ed7353dadf42ba59fde
diff --git a/dev-python/boto3/boto3-1.37.1.ebuild b/dev-python/boto3/boto3-1.37.1.ebuild
new file mode 100644
index 000000000000..b087a88814e8
--- /dev/null
+++ b/dev-python/boto3/boto3-1.37.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}