summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-04 13:47:30 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-04 13:59:58 -0800
commitc491d8862aa6fde0d24081a96bdcd54f7343142f (patch)
treefefce7f9061d2d681a56f73c633721d26a13367c /dev-python/bleach/bleach-3.1.0-r1.ebuild
parentapp-crypt/gcr: version bump to 3.34 + switch to Python 3 (diff)
downloadgentoo-c491d8862aa6fde0d24081a96bdcd54f7343142f.tar.gz
gentoo-c491d8862aa6fde0d24081a96bdcd54f7343142f.tar.bz2
gentoo-c491d8862aa6fde0d24081a96bdcd54f7343142f.zip
dev-python/bleach-3.1.0-r1: revbump, add py38, distutils helper
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/bleach/bleach-3.1.0-r1.ebuild')
-rw-r--r--dev-python/bleach/bleach-3.1.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/bleach/bleach-3.1.0-r1.ebuild b/dev-python/bleach/bleach-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..51c292c42449
--- /dev/null
+++ b/dev-python/bleach/bleach-3.1.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest