summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-01-22 22:57:53 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-01-22 23:00:40 +0100
commit0941e87b3bf05ac5cec34c55e075b8c3b8d1dcec (patch)
tree9ba6cb3d2a7494f10eccbcc0dca3e4f647636e40 /dev-python/awscli/awscli-1.16.308.ebuild
parentdev-python/awscli: bump to v1.16.314 (diff)
downloadgentoo-0941e87b3bf05ac5cec34c55e075b8c3b8d1dcec.tar.gz
gentoo-0941e87b3bf05ac5cec34c55e075b8c3b8d1dcec.tar.bz2
gentoo-0941e87b3bf05ac5cec34c55e075b8c3b8d1dcec.zip
dev-python/awscli: drop old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/awscli/awscli-1.16.308.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.16.308.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/awscli/awscli-1.16.308.ebuild b/dev-python/awscli/awscli-1.16.308.ebuild
deleted file mode 100644
index 114534d56046..000000000000
--- a/dev-python/awscli/awscli-1.16.308.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Universal Command Line Environment for AWS"
-HOMEPAGE="https://pypi.org/project/awscli/"
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# requires network access
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/botocore-1.13.44[${PYTHON_USEDEP}]
- <dev-python/colorama-0.3.9.0[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- <dev-python/rsa-3.5.0.0[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.2.0[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5.2.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/aws-cli-${PV}"
-
-python_test() {
- nosetests -vv || die
-}
-
-python_install_all() {
- newbashcomp bin/aws_bash_completer aws
-
- insinto /usr/share/zsh/site-functions
- newins bin/aws_zsh_completer.sh _aws
-
- distutils-r1_python_install_all
-
- rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
-}