summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-28 06:47:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-28 07:00:15 +0200
commitcb87d9b0a8b684b136be31d919a9921ed1bad0dd (patch)
treefc1af0a5fb81e9a623c5f8f7337c09f89f38a892 /dev-python/autopage/autopage-0.5.1.ebuild
parentdev-python/fakeredis: Bump to 1.8 (diff)
downloadgentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.tar.gz
gentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.tar.bz2
gentoo-cb87d9b0a8b684b136be31d919a9921ed1bad0dd.zip
dev-python/autopage: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopage/autopage-0.5.1.ebuild')
-rw-r--r--dev-python/autopage/autopage-0.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/autopage/autopage-0.5.1.ebuild b/dev-python/autopage/autopage-0.5.1.ebuild
new file mode 100644
index 000000000000..8ee86b0e8ad2
--- /dev/null
+++ b/dev-python/autopage/autopage-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://github.com/zaneb/autopage/
+ https://pypi.org/project/autopage/
+"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}