summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-30 05:52:55 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-30 05:52:55 +0200
commit8d1addaeb600ac40416267d968728ac611b62abf (patch)
treebd4c1300902081ebf6e0218715096f36ac932fd7 /dev-python/asteval
parentdev-python/asteval: Remove old (diff)
downloadgentoo-8d1addaeb600ac40416267d968728ac611b62abf.tar.gz
gentoo-8d1addaeb600ac40416267d968728ac611b62abf.tar.bz2
gentoo-8d1addaeb600ac40416267d968728ac611b62abf.zip
dev-python/asteval: Bump to 1.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asteval')
-rw-r--r--dev-python/asteval/Manifest1
-rw-r--r--dev-python/asteval/asteval-1.0.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/asteval/Manifest b/dev-python/asteval/Manifest
index a914e07b00dc..54d188d27705 100644
--- a/dev-python/asteval/Manifest
+++ b/dev-python/asteval/Manifest
@@ -1 +1,2 @@
DIST asteval-1.0.4.gh.tar.gz 46374 BLAKE2B 4a3133457a752bc99a68fc4bffeb8aab8b4340ef21f8bae75d9131a5bcaa7eb4d081cacdfa7d9396565cc744a4d997e33516ba9cb0ae290392b06bfbcc608f27 SHA512 cf29562a2792013ed8fc7c14aaa261650b05037ee92ab75f8c79a1a235c59e8ee4768955c03ed615798666bfb62bf2ca37105dc93c1a4f56bcf446a0e4ba01f6
+DIST asteval-1.0.5.gh.tar.gz 46599 BLAKE2B 159076d1cdcac9ee6d9bf319ccb6ffcdb775fea7a930dce85d1171ede4f3e2b6acf1e9293cfe9d44e8da2762f20507c0781492fa5e6054a4f28fe836581af958 SHA512 a85cfde94e9f8d224d83b434d028bb91f2eec415090a14c2e8ceeecaba76c8e29c795bd54d9cfabc070dc9ee27cc492cfd533f35c272bf0649e284375b84ba7e
diff --git a/dev-python/asteval/asteval-1.0.5.ebuild b/dev-python/asteval/asteval-1.0.5.ebuild
new file mode 100644
index 000000000000..5162e3ac4666
--- /dev/null
+++ b/dev-python/asteval/asteval-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://lmfit.github.io/asteval/
+ https://github.com/lmfit/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/lmfit/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}