summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 17:07:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 17:41:58 +0200
commit9011773e29452a3170a55b2ea63dbd3da1e12e81 (patch)
tree9817c5b335e521283919b85a29d241befa5c8fbc /dev-python/appdirs
parentdev-python/jaraco-classes: Enable py3.12 (diff)
downloadgentoo-9011773e29452a3170a55b2ea63dbd3da1e12e81.tar.gz
gentoo-9011773e29452a3170a55b2ea63dbd3da1e12e81.tar.bz2
gentoo-9011773e29452a3170a55b2ea63dbd3da1e12e81.zip
dev-python/appdirs: Restore original build system
Restore the original setuptools build system since setuptools no longer requires appdirs, and therefore there are no bootstrap concerns anymore. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/appdirs')
-rw-r--r--dev-python/appdirs/Manifest1
-rw-r--r--dev-python/appdirs/appdirs-1.4.4-r3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/appdirs/Manifest b/dev-python/appdirs/Manifest
index 97a4d25f7608..b25cccf5cc50 100644
--- a/dev-python/appdirs/Manifest
+++ b/dev-python/appdirs/Manifest
@@ -1 +1,2 @@
+DIST appdirs-1.4.4.gh.tar.gz 9840 BLAKE2B cb9466f4a7f7c1d6f5b6d7ca031820ec4d3450afcaa8ba571e35387c3109ede4e2afbf2c1141a9d01d13798f55524d5efd3fa12546a9378abbda405353938d79 SHA512 4c0e1e8dcd3f91b8b2d215b3f1e2ffaa85137fe054d07d3a2d442b1419e3b44e96fdea1620bd000bd3f4744f71b71f07280094f073df0ff008fac902af614656
DIST appdirs-1.4.4.tar.gz 9840 BLAKE2B cb9466f4a7f7c1d6f5b6d7ca031820ec4d3450afcaa8ba571e35387c3109ede4e2afbf2c1141a9d01d13798f55524d5efd3fa12546a9378abbda405353938d79 SHA512 4c0e1e8dcd3f91b8b2d215b3f1e2ffaa85137fe054d07d3a2d442b1419e3b44e96fdea1620bd000bd3f4744f71b71f07280094f073df0ff008fac902af614656
diff --git a/dev-python/appdirs/appdirs-1.4.4-r3.ebuild b/dev-python/appdirs/appdirs-1.4.4-r3.ebuild
new file mode 100644
index 000000000000..b06ec56d0633
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.4-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://github.com/ActiveState/appdirs/
+ https://pypi.org/project/appdirs/
+"
+SRC_URI="
+ https://github.com/ActiveState/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" test/test_api.py -v || die "Tests fail with ${EPYTHON}"
+}