summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 07:33:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 07:33:12 +0200
commit43baf0c7adc84dd420c41fc70f37d8a1e8a915b5 (patch)
treed69c60016b727ffc63a9328a5a282c2e82ba4394 /dev-python/apispec
parentdev-python/osrf_pycommon: Bump to 1.0.0 (diff)
downloadgentoo-43baf0c7adc84dd420c41fc70f37d8a1e8a915b5.tar.gz
gentoo-43baf0c7adc84dd420c41fc70f37d8a1e8a915b5.tar.bz2
gentoo-43baf0c7adc84dd420c41fc70f37d8a1e8a915b5.zip
dev-python/apispec: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-5.0.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 8a2889b1880d..df8d230559cc 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -4,3 +4,4 @@ DIST apispec-4.5.0.tar.gz 65423 BLAKE2B ce6cc6f466d274db6aa5f8b27c3a9340daff7934
DIST apispec-4.6.0.tar.gz 66147 BLAKE2B 98127cb2bf938cc1928e13e1169804eea174351a0f4eeaabc801da711d0861bc35a9761e9f1bc478a44d6a85989a1aba1840b3e472599064240a880fda8e45b4 SHA512 b030e5400a9abce06576406f83befb298814617e06729f29c2ee70517cf456901b67e60880b3b4baec096717a91341e8268bcd8e01fd566b7c6e03709afd7c3b
DIST apispec-4.7.0.tar.gz 66274 BLAKE2B dbb14dd831eddeb9f086643b6182ccc3e529e22ad7e31d1d4dd2dce54edf76c6cf01a74438383df5ccec18cf863334d5cdbd45214791c01632d7f7efa63f7aa3 SHA512 53c0a1e6db81439a7c3f8e933cac28003dd84444e65986a29aef8a6ec761999c84417902448288d69c5873d12dded2156e79bedc5bd4bd0fd472ea014e65a6c7
DIST apispec-4.7.1.tar.gz 66356 BLAKE2B f78ab7f10c7a10f3d62b4d02e5a33cc1972aea0b33af1c485a11c2c415b2913a4d8151a9aa44de9876fa1ec6ebe02d448fb50dcc573e6a4779265ee07bda0329 SHA512 e5ead9a867d9dd18f2fb7509b6ef4afd9ec04cc102f55684a66e8f5ebe1b8e3e4129c62b7fd50f0a337547336375cee612e1bec620fa957f8f90d11968538c8e
+DIST apispec-5.0.0.tar.gz 68795 BLAKE2B 42b4ea7d825fc94c6ca904df56a900b52ecd3fda78b3079103370c6cb362cea6338251d344c970c0ad0380d8b39931f6fc38f3e71dc4c31ace0763c6e9721f73 SHA512 1e3d4c06713081d90d5d8650e7aeedd12248ef9a43ced6681be4e9dbf4563b7390cabf3423ea2c1bfda6900cd193efa4e2cacdac77350fcf2e83cfc30580c98e
diff --git a/dev-python/apispec/apispec-5.0.0.ebuild b/dev-python/apispec/apispec-5.0.0.ebuild
new file mode 100644
index 000000000000..9965d2dcdf04
--- /dev/null
+++ b/dev-python/apispec/apispec-5.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.13.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+python_test() {
+ local deselect=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}