summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 12:26:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-18 12:46:46 +0200
commita52206a7038e5ee992f0e811760c73433835ae66 (patch)
tree50f819580c7d35c7cd14ec3c2715c086f5f81cec /dev-python/ansicolor
parentdev-python/PyPDF2: enable py3.11 (diff)
downloadgentoo-a52206a7038e5ee992f0e811760c73433835ae66.tar.gz
gentoo-a52206a7038e5ee992f0e811760c73433835ae66.tar.bz2
gentoo-a52206a7038e5ee992f0e811760c73433835ae66.zip
dev-python/ansicolor: EAPI8, py3.11, PEP517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild29
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild16
2 files changed, 39 insertions, 6 deletions
diff --git a/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..ceb39bf7b7df
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
index d678863551e3..ceb39bf7b7df 100644
--- a/dev-python/ansicolor/ansicolor-9999.ebuild
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
# pypi tars don't include tests and github repo is missing release tags,
# so only enabling tests for 9999 at this time
- distutils_enable_tests pytest
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,3 +25,5 @@ HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansico
LICENSE="Apache-2.0"
SLOT="0"
+
+distutils_enable_tests pytest