summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-05-31 23:18:53 -0700
committerMichał Górny <mgorny@gentoo.org>2020-06-02 09:11:01 +0200
commit3e24f76827fb4b305327d68a57216e4c73befd00 (patch)
tree451bec28ede329e97210eb2421f8d88b0ffb60b0 /dev-python/Rx/Rx-3.1.0.ebuild
parentdev-python/wcwidth: Bump to 0.2.2 (diff)
downloadgentoo-3e24f76827fb4b305327d68a57216e4c73befd00.tar.gz
gentoo-3e24f76827fb4b305327d68a57216e4c73befd00.tar.bz2
gentoo-3e24f76827fb4b305327d68a57216e4c73befd00.zip
dev-python/Rx-3.1.0: bump
* Switch to EAPI 7 * Support Python 3.7/3.8/3.9 * Run tests Bug: https://bugs.gentoo.org/708270 Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/16040 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Rx/Rx-3.1.0.ebuild')
-rw-r--r--dev-python/Rx/Rx-3.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Rx/Rx-3.1.0.ebuild b/dev-python/Rx/Rx-3.1.0.ebuild
new file mode 100644
index 000000000000..dca57f5969d9
--- /dev/null
+++ b/dev-python/Rx/Rx-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 python3_9 )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="https://github.com/ReactiveX/${MY_P}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}