summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 14:23:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 14:29:05 +0100
commit97771b1b14bd8ae25d6ece32b194e5434eca836d (patch)
treeaf43d4011c7b347e5420e8650f65414964e285fc /dev-python/QtPy
parentmedia-video/vidify: youtube-dl --> yt-dlp (diff)
downloadgentoo-97771b1b14bd8ae25d6ece32b194e5434eca836d.tar.gz
gentoo-97771b1b14bd8ae25d6ece32b194e5434eca836d.tar.bz2
gentoo-97771b1b14bd8ae25d6ece32b194e5434eca836d.zip
dev-python/QtPy: drop pyside2,py310 restriction
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/QtPy-1.11.3-r1.ebuild (renamed from dev-python/QtPy/QtPy-1.11.3.ebuild)47
1 files changed, 16 insertions, 31 deletions
diff --git a/dev-python/QtPy/QtPy-1.11.3.ebuild b/dev-python/QtPy/QtPy-1.11.3-r1.ebuild
index 7e702e2e474e..6ced63406d95 100644
--- a/dev-python/QtPy/QtPy-1.11.3.ebuild
+++ b/dev-python/QtPy/QtPy-1.11.3-r1.ebuild
@@ -23,14 +23,7 @@ _IUSE_QT_MODULES="
IUSE="+pyqt5 pyside2 ${_IUSE_QT_MODULES}"
unset _IUSE_QT_MODULES
-# PySide2 does not support python3_10, nor is it likely that it will in the
-# future since upstream appears to be focussing on PySide6 for Qt6 instead
-# (which is compatible with python3_10). So if we want to use python3_10
-# we have to force disable pyside2.
-REQUIRED_USE="
- || ( pyqt5 pyside2 )
- python_targets_python3_10? ( pyqt5 !pyside2 )
-"
+REQUIRED_USE="|| ( pyqt5 pyside2 )"
# These flags are currently *not* common to both the PySide2 and PyQt5 ebuild
# Disable them for now, please check periodically if this is still up to date.
@@ -73,15 +66,13 @@ RDEPEND="
webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
)
pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
- dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
- dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
- dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
- declarative? ( dev-python/pyside2[qml,quick] )
- ' python3_{7..9} )
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[designer?,gui?,help?,location?,multimedia?]
+ dev-python/pyside2[network?,opengl(+)?,positioning?,printsupport?]
+ dev-python/pyside2[sensors?,serialport(+)?,speech?,sql?,svg?]
+ dev-python/pyside2[testlib?,webchannel?,webengine?,websockets?]
+ dev-python/pyside2[widgets?,x11extras?,xml?,xmlpatterns?]
+ declarative? ( dev-python/pyside2[qml,quick] )
)
"
@@ -100,15 +91,13 @@ BDEPEND="
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
)
pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
- dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- ' python3_{7..9} )
+ dev-python/pyside2[${PYTHON_USEDEP}]
+ dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
+ dev-python/pyside2[location,multimedia,network,opengl(+),positioning]
+ dev-python/pyside2[printsupport,qml,quick,script,scripttools,scxml]
+ dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
+ dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
+ dev-python/pyside2[xml,xmlpatterns]
)
)
"
@@ -142,11 +131,7 @@ python_test() {
QT_API="pyqt5" epytest
fi
if use pyside2; then
- if [[ "${EPYTHON}" == "python3.10" ]]; then
- return
- else
- QT_API="pyside2" epytest
- fi
+ QT_API="pyside2" epytest
fi
}