summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-12-03 19:38:50 +0100
committerDavide Pesavento <pesa@gentoo.org>2015-12-03 19:39:34 +0100
commit333a65ec4744d0d64362756ea88ec0f3b855d603 (patch)
treee3a73c4b470560e6988dbb2cf7d60fb1e3f8b8e3 /dev-python/PyQt5
parentsys-fs/zfs-kmod-0.6.5.3-r1: Block <sys-kernel/spl-0.6.5.3-r1 (diff)
downloadgentoo-333a65ec4744d0d64362756ea88ec0f3b855d603.tar.gz
gentoo-333a65ec4744d0d64362756ea88ec0f3b855d603.tar.bz2
gentoo-333a65ec4744d0d64362756ea88ec0f3b855d603.zip
dev-python/PyQt5: add several missing REQUIRED_USE
Apparently configure.py does not list all these dependencies, and does not check if they are satisfied at build time. But their lack causes ImportErrors at runtime. Gentoo-Bug: 567394 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.5.1.ebuild14
-rw-r--r--dev-python/PyQt5/PyQt5-5.5.ebuild2
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.5.1.ebuild b/dev-python/PyQt5/PyQt5-5.5.1.ebuild
index 24b724f0cd40..b0d903df96d9 100644
--- a/dev-python/PyQt5/PyQt5-5.5.1.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.5.1.ebuild
@@ -29,14 +29,28 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="dbus debug declarative designer doc examples gles2 gui help multimedia
network opengl positioning printsupport sensors serialport sql svg
testlib webchannel webkit websockets widgets x11extras xmlpatterns"
+
+# The requirements below were extracted from configure.py
+# and from the output of 'grep -r "%Import " "${S}"/sip'
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
+ declarative? ( gui network )
+ designer? ( widgets )
+ help? ( gui widgets )
+ multimedia? ( gui network )
+ opengl? ( gui widgets )
positioning? ( gui )
+ printsupport? ( widgets )
sensors? ( gui )
serialport? ( gui )
sql? ( widgets )
+ svg? ( gui widgets )
testlib? ( widgets )
webchannel? ( network )
+ webkit? ( gui network printsupport widgets )
+ websockets? ( network )
+ widgets? ( gui )
+ xmlpatterns? ( network )
"
# Minimal supported version of Qt.
diff --git a/dev-python/PyQt5/PyQt5-5.5.ebuild b/dev-python/PyQt5/PyQt5-5.5.ebuild
index 6ce5a5116fa4..f7a2f64f7056 100644
--- a/dev-python/PyQt5/PyQt5-5.5.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.5.ebuild
@@ -29,6 +29,8 @@ KEYWORDS="amd64 arm ~x86"
IUSE="dbus debug declarative designer doc examples gles2 gui help multimedia
network opengl positioning printsupport sensors serialport sql svg
testlib webchannel webkit websockets widgets x11extras xmlpatterns"
+
+# The requirements below were extracted from configure.py
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
positioning? ( gui )