summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-09-11 12:50:48 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-09-22 15:59:45 +0200
commit4fb4301455d4f949e9ae2079856af929e11f4336 (patch)
tree940045d776dcff81ba05cc8fcaeb36f33064e148 /dev-python/CommonMark
parentnet-vpn/openvpn: remove unused patch/file. (diff)
downloadgentoo-4fb4301455d4f949e9ae2079856af929e11f4336.tar.gz
gentoo-4fb4301455d4f949e9ae2079856af929e11f4336.tar.bz2
gentoo-4fb4301455d4f949e9ae2079856af929e11f4336.zip
dev-python/CommonMark: version bump to 0.7.4 and fixes.
Renamed cmark executable to cmark.py due file collision with app-text/cmark. Added USE-flag "test". Gentoo-Bug: https://bugs.gentoo.org/627034 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5686
Diffstat (limited to 'dev-python/CommonMark')
-rw-r--r--dev-python/CommonMark/CommonMark-0.7.4.ebuild45
-rw-r--r--dev-python/CommonMark/Manifest1
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/CommonMark/CommonMark-0.7.4.ebuild b/dev-python/CommonMark/CommonMark-0.7.4.ebuild
new file mode 100644
index 000000000000..bd4fc9bf81bd
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.7.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/flake8-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = CommonMark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}
diff --git a/dev-python/CommonMark/Manifest b/dev-python/CommonMark/Manifest
index 8f4c8d70ce56..7fe8eb84120e 100644
--- a/dev-python/CommonMark/Manifest
+++ b/dev-python/CommonMark/Manifest
@@ -1,2 +1,3 @@
DIST CommonMark-0.5.4.tar.gz 120316 SHA256 34d73ec8085923c023930dfc0bcd1c4286e28a2a82de094bb72fabcc0281cbe5 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad WHIRLPOOL f375b772faff450af98d73b3559dabe7b7369951cd8cf9ea45046bf5de875022212b7e92daee3fa7d3fb63d44894a301991a4561ac8a8b0c78eef64c83062fad
DIST CommonMark-0.7.3.tar.gz 85177 SHA256 5f20ebd91614c8d339d4cded314894feb5d9a54c3b52c1ff9883794557149ea8 SHA512 34ddf0539b54d79cd16356124a15e4f51076a7afdde78fbaa0cab06658279357c5523d89bdfa7d595d85da9df9b194491ddac22b78444b230f53298ffd11c8cf WHIRLPOOL 41b1da6e2c1479b8b47b048d529282a8618f455653ad88e65f1460c55c74ccb7df563e159470ae8d912deede190d5da18b88111420a0d48fe264724e993871ef
+DIST CommonMark-0.7.4.tar.gz 87841 SHA256 24678b72094398df96312fb927e274ccaf5148f25e47aca9f7fc062693ae7577 SHA512 7c76a5f0dec02e9ae8c2f73ebd2980a5a684b43ee8a82ea23b72c7f2332e1d4316a7b2d7b66ad8fe912803115a57e03b2ae4c7b042cc53e1205e579093053b89 WHIRLPOOL 22a9ce7fd17dbf2b441b870b458a0cd257f6e343aeae837ebad452d4ada58dceaede631409c11ba87d81ba4fce14d68d2c6e9e9d3e0a42de2b3aac790b4adf75