summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-16 06:30:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-16 06:32:41 +0200
commitdfd4989272f6f56650541febb23bccec1ff0045b (patch)
tree252b11897778e5ff06e6204bf71dfce964ef1fe6 /dev-python/Babel
parentmedia-sound/abcmidi: bump to 2022.06.14 (diff)
downloadgentoo-dfd4989272f6f56650541febb23bccec1ff0045b.tar.gz
gentoo-dfd4989272f6f56650541febb23bccec1ff0045b.tar.bz2
gentoo-dfd4989272f6f56650541febb23bccec1ff0045b.zip
dev-python/Babel: Simplify the regen logic
Rather than using any-r1 approach to the regen with "slightly wrong" BDEPEND, just do it as a part of normal phase. The end result is pretty much the same, and it avoids having to define python_check_deps(). Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.10.2.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/Babel/Babel-2.10.2.ebuild b/dev-python/Babel/Babel-2.10.2.ebuild
index af5ed2211ba1..02e77dc3bc66 100644
--- a/dev-python/Babel/Babel-2.10.2.ebuild
+++ b/dev-python/Babel/Babel-2.10.2.ebuild
@@ -44,18 +44,16 @@ BDEPEND="
distutils_enable_sphinx docs
distutils_enable_tests pytest
-python_check_deps() {
- if [[ ${EPYTHON} == python3.8 ]] ; then
- python_has_version "dev-python/backports-zoneinfo[${PYTHON_USEDEP}]" || return 1
- fi
-
- python_has_version "dev-python/pytz[${PYTHON_USEDEP}]"
-}
-
-python_configure_all() {
+src_prepare() {
rm babel/locale-data/*.dat || die
rm babel/global.dat || die
- "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ if [[ ! -f babel/global.dat ]]; then
+ "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
+ fi
}
python_test() {