summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2023-03-08 13:08:12 -0500
committerBrian Evans <grknight@gentoo.org>2023-03-08 13:08:12 -0500
commitc7f6c7851908d69cb9555704f08334b2afdec5d6 (patch)
treecf51c0886f74944e6dfae9c9bcf5c360bcb043bc /dev-php
parentdev-python/resolvelib: Bump to 1.0.0 (diff)
downloadgentoo-c7f6c7851908d69cb9555704f08334b2afdec5d6.tar.gz
gentoo-c7f6c7851908d69cb9555704f08334b2afdec5d6.tar.bz2
gentoo-c7f6c7851908d69cb9555704f08334b2afdec5d6.zip
dev-php/pecl-ssh2: Update targets
Closes: https://bugs.gentoo.org/899738 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.3.1-r1.ebuild19
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild4
2 files changed, 21 insertions, 2 deletions
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.3.1-r1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..405a6b3e9a07
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.3.1-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+# Upstream notes say there are errors with gcrypt backend
+DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
+RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
index b5c9256a3d98..8206375e6835 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
PHP_EXT_NAME="ssh2"
-USE_PHP="php7-4 php8-0 php8-1"
+USE_PHP="php7-4 php8-0 php8-1 php8-2"
EGIT_REPO_URI="https://github.com/php/pecl-networking-ssh2.git"
inherit php-ext-source-r3 git-r3