summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Tk-TableMatrix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Tk-TableMatrix')
-rw-r--r--dev-perl/Tk-TableMatrix/Manifest1
-rw-r--r--dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r1.ebuild31
-rw-r--r--dev-perl/Tk-TableMatrix/files/pTk-1.22.patch18
-rw-r--r--dev-perl/Tk-TableMatrix/metadata.xml11
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/Tk-TableMatrix/Manifest b/dev-perl/Tk-TableMatrix/Manifest
new file mode 100644
index 000000000000..8db1f50fcf46
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/Manifest
@@ -0,0 +1 @@
+DIST Tk-TableMatrix-1.23.tar.gz 318954 SHA256 ce9ace8d1c1245b80ea6b2e72ee3e7f75ca4111026e403134b8ecad02ec931da SHA512 115eb2a71c3725392f2bcf5e468bc84844c8a5ad3db221205876d7de6486833a3fd4e98aa32e21f5dcf038a38f9d98721adeebb1f9cd0990359aec7d07f6f32e WHIRLPOOL ce54205cbfc7102fb0000d6520ebc275fcd6f3c81e3eb402acb48e30d1eb3f75a10423c64ab315b455123d6ce7f6d49c4990646726a4f8cd6b7d453c312fee4b
diff --git a/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r1.ebuild b/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r1.ebuild
new file mode 100644
index 000000000000..e94f98cd9a67
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/Tk-TableMatrix-1.230.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CERNEY
+MODULE_VERSION=1.23
+inherit perl-module
+
+DESCRIPTION="Perl module for Tk-TableMatrix"
+
+#SRC_TEST="do"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE=""
+
+DEPEND="dev-perl/perl-tk"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/pTk-1.22.patch" )
+
+src_install() {
+ perl-module_src_install
+
+ # Clean out stray conflicting file - its generated by perl-tk already.
+ # Bug 169294
+ rm "${D}"/${VENDOR_ARCH}/auto/Tk/pTk/extralibs.ld || die
+}
diff --git a/dev-perl/Tk-TableMatrix/files/pTk-1.22.patch b/dev-perl/Tk-TableMatrix/files/pTk-1.22.patch
new file mode 100644
index 000000000000..ff9938535b69
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/files/pTk-1.22.patch
@@ -0,0 +1,18 @@
+--- pTk/Makefile.PL.old 2006-05-01 18:09:31.000000000 -0400
++++ pTk/Makefile.PL 2006-05-01 18:10:05.000000000 -0400
+@@ -234,11 +234,11 @@ sub MY::postamble {
+ my $self = shift;
+ my $dep = $self->Tk::MMutil::mTk_postamble;
+
+-$dep .= $self->dir_target(@{$self->{'dir_targets'}});
+-
+-$dep .= "config :: " . join(" \\\n\t",map($self->catfile($_,".exists"),@{$self->{'dir_targets'}})) .
+- "\n\t".$self->{NOECHO}."\$(NOOP)\n";
+
++if ($Tk::MMutil::IsWin32 or ($win_arch eq 'MSWin32' and $^O eq 'cygwin'))
++ {
++ my $cc = $Config{'cc'};
++ }
+
+ $dep . '
+
diff --git a/dev-perl/Tk-TableMatrix/metadata.xml b/dev-perl/Tk-TableMatrix/metadata.xml
new file mode 100644
index 000000000000..8ad76deef2c1
--- /dev/null
+++ b/dev-perl/Tk-TableMatrix/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Tk-TableMatrix</remote-id>
+ <remote-id type="cpan-module">Tk::TableMatrix</remote-id>
+ <remote-id type="cpan-module">Tk::TableMatrix::Spreadsheet</remote-id>
+ <remote-id type="cpan-module">Tk::TableMatrix::SpreadsheetHideRows</remote-id>
+ </upstream>
+</pkgmetadata>