summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-09 19:44:51 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-09 19:45:04 +1300
commitc330e65c805f41456c41e50bcc973085203c688b (patch)
treed47766a7da96a4fb33ceb75e6fb861474075e525 /dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild
parentdev-perl/Test-Warn: Bump to version 0.320.0 (diff)
downloadgentoo-c330e65c805f41456c41e50bcc973085203c688b.tar.gz
gentoo-c330e65c805f41456c41e50bcc973085203c688b.tar.bz2
gentoo-c330e65c805f41456c41e50bcc973085203c688b.zip
dev-perl/Test2-Plugin-NoWarnings: Bump to version 0.60.0
Upstream: - Emit warnings as Ok events instead of Warning events to work around limitations in the core TAP formatter not emitting warnings in subtests Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild')
-rw-r--r--dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild b/dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild
new file mode 100644
index 000000000000..4fb975ca184d
--- /dev/null
+++ b/dev-perl/Test2-Plugin-NoWarnings/Test2-Plugin-NoWarnings-0.60.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Fail if tests warn"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Test-Simple-1.302.15
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/IPC-Run3
+ >=dev-perl/Test2-Suite-0.0.15
+ )
+"