summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-09 18:02:37 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-09 18:03:10 +1300
commitd69ae6d5e55619e8fa17ca5396c8a59afc1e584c (patch)
tree6b6a5044df9a0e2f90c488462e03a2133e19225b /dev-perl/Test-WWW-Mechanize
parentsys-devel/sparse: version bump (diff)
downloadgentoo-d69ae6d5e55619e8fa17ca5396c8a59afc1e584c.tar.gz
gentoo-d69ae6d5e55619e8fa17ca5396c8a59afc1e584c.tar.bz2
gentoo-d69ae6d5e55619e8fa17ca5396c8a59afc1e584c.zip
dev-perl/Test-WWW-Mechanize: Bump to version 1.480.0
- EAPI6 - Purge pod author tests - Parallel tests Upstream: - Use HTML::Lint API correctly to catch all errors at end of page - Add header_exists_ok, lacks_header, header_is, header_like, delete_ok methods - Don't auto-assign a description in scraped_id_is - Give proper diagnostics if scraped_id_is is not found - content_contains now fails when called with regex - content_like now fails when not called with a regex - Forbid testing URLs outside document tree in test suite - Fix restrictive optimization in scrape_text_by_id Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Test-WWW-Mechanize')
-rw-r--r--dev-perl/Test-WWW-Mechanize/Manifest1
-rw-r--r--dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.480.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Test-WWW-Mechanize/Manifest b/dev-perl/Test-WWW-Mechanize/Manifest
index e5b2e4588f26..1aa6e4f51fa5 100644
--- a/dev-perl/Test-WWW-Mechanize/Manifest
+++ b/dev-perl/Test-WWW-Mechanize/Manifest
@@ -1 +1,2 @@
DIST Test-WWW-Mechanize-1.44.tar.gz 25824 BLAKE2B 97e2afd681e0ba6ccdc80f89c29357cd444ef34f6f1a4b4105ff73a61b2da36c4669de244aced0bb2435aa3e2639cf4a989b455c0c4c82ed44fd76cd318366f5 SHA512 ab6f8c210a42ef14cd83bc4644a338f76d2e0c908855fe4fbf03b2dc3376476e418b5e71a080cf889b0c6a8f20185def1b54568e1cb2ba130fe484516614393d
+DIST Test-WWW-Mechanize-1.48.tar.gz 28897 BLAKE2B af9ebf598c7c6606636c5dc360f7c690e48dc9d340152ae706246bac3d7ef14593ddb9e6c1968fa4b327e47c3e711e45354767394d404c73b6ea1b4dbef0f961 SHA512 90a1d365479245d159ba7aa954bb01b617f1526423a00b41f3347e0e708a3eb79f0ba5a20315e74032d817154e52ef6178571528bcc183e38a9c53577ef8235d
diff --git a/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.480.0.ebuild b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.480.0.ebuild
new file mode 100644
index 000000000000..f114d59e7b08
--- /dev/null
+++ b/dev-perl/Test-WWW-Mechanize/Test-WWW-Mechanize-1.480.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.48
+inherit perl-module
+
+DESCRIPTION="Testing-specific WWW::Mechanize subclass"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Carp-Assert-More
+ dev-perl/HTML-Parser
+ >=dev-perl/libwww-perl-6.200.0
+ >=dev-perl/Test-LongString-0.150.0
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/URI
+ >=dev-perl/WWW-Mechanize-1.680.0
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/HTTP-Server-Simple-0.420.0
+ )
+"
+PERL_RM_FILES=( "t/pod.t" "t/pod-coverage.t" )