summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-29 02:43:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-29 02:58:19 +0200
commit670aedab6f86c8296c58df63570a71c9f37f31f2 (patch)
tree64cdb62295687eb98dd6815579a30fa63ec6ff8d /dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
parentapp-emulation/wine-staging: Drop old (diff)
downloadgentoo-670aedab6f86c8296c58df63570a71c9f37f31f2.tar.gz
gentoo-670aedab6f86c8296c58df63570a71c9f37f31f2.tar.bz2
gentoo-670aedab6f86c8296c58df63570a71c9f37f31f2.zip
dev-perl/Test-Regexp: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild')
-rw-r--r--dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
new file mode 100644
index 000000000000..4e755f481fef
--- /dev/null
+++ b/dev-perl/Test-Regexp/Test-Regexp-2017040101.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ABIGAIL
+DIST_VERSION=2017040101
+inherit perl-module
+
+DESCRIPTION="Provide commonly requested regular expressions"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/perl-Test-Simple
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-1.1.14 )
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ # Omit code coverage / documentation tests
+ perl_rm_files t/{950,960,980,981,982}*.t
+
+ perl-module_src_test
+}