summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-18 05:05:36 +0100
committerSam James <sam@gentoo.org>2023-06-18 05:05:36 +0100
commit44f8cb7ba94b92a6258cb408e0e03d1f38280688 (patch)
tree517e3d51c13531a326366405f5e14acaf272fceb /dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild
parentdev-perl/Test-LWP-UserAgent: add 0.36.0 (diff)
downloadgentoo-44f8cb7ba94b92a6258cb408e0e03d1f38280688.tar.gz
gentoo-44f8cb7ba94b92a6258cb408e0e03d1f38280688.tar.bz2
gentoo-44f8cb7ba94b92a6258cb408e0e03d1f38280688.zip
dev-perl/Test-Inter: add 1.100.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild')
-rw-r--r--dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild b/dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild
new file mode 100644
index 000000000000..cb6b4946a005
--- /dev/null
+++ b/dev-perl/Test-Inter/Test-Inter-1.100.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SBECK
+DIST_VERSION=1.10
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Framework for more readable interactive test scripts"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND=">=virtual/perl-ExtUtils-MakeMaker-6.300.0"
+RDEPEND="virtual/perl-IO"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t t/_pod_coverage.t t/_pod.t
+ perl-module_src_test
+}