summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-09 01:48:51 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-09 02:15:50 +0200
commita1c0e349e96d1e6e46149d2308a7f202cfc4b313 (patch)
tree39b115980884175570efc0c17b07c79262f7e662 /dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild
parentdev-perl/Sphinx-Config: EAPI=8 bump (diff)
downloadgentoo-a1c0e349e96d1e6e46149d2308a7f202cfc4b313.tar.gz
gentoo-a1c0e349e96d1e6e46149d2308a7f202cfc4b313.tar.bz2
gentoo-a1c0e349e96d1e6e46149d2308a7f202cfc4b313.zip
dev-perl/Sphinx-Search: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild')
-rw-r--r--dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild b/dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild
new file mode 100644
index 000000000000..5a9414418423
--- /dev/null
+++ b/dev-perl/Sphinx-Search/Sphinx-Search-0.310.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=JJSCHUTZ
+DIST_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Perl API client for Sphinx search engine"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Accessor
+ dev-perl/DBI
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ dev-perl/List-MoreUtils
+ dev-perl/File-SearchPath
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt
+ dev-perl/Path-Class
+ virtual/perl-Socket
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=( "t/pod-coverage.t" "t/pod.t" "t/boilerplate.t" )