summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-16 09:54:03 +0100
committerSam James <sam@gentoo.org>2023-09-16 10:26:32 +0100
commit0d768cc1df7fc26ad36e27a0a64211365b6b866c (patch)
tree016337c2415db79a01721fdbb4d2c970686cf716 /dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild
parentdev-perl/Perl-Tidy: add 20230912.0.0 (diff)
downloadgentoo-0d768cc1df7fc26ad36e27a0a64211365b6b866c.tar.gz
gentoo-0d768cc1df7fc26ad36e27a0a64211365b6b866c.tar.bz2
gentoo-0d768cc1df7fc26ad36e27a0a64211365b6b866c.zip
dev-perl/Net-DNS-SEC: add 1.220.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild')
-rw-r--r--dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild b/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild
new file mode 100644
index 000000000000..b7345690f071
--- /dev/null
+++ b/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.22
+inherit perl-module
+
+DESCRIPTION="DNSSEC extensions to Net::DNS"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ dev-libs/openssl:=
+ >=virtual/perl-Carp-1.100.0
+ >=virtual/perl-Exporter-5.560.0
+ >=virtual/perl-File-Spec-3.290.0
+ >=virtual/perl-MIME-Base64-2.130.0
+ >=dev-perl/Net-DNS-1.80.0
+"
+DEPEND="dev-libs/openssl:="
+# pkgconfig is used to find openssl
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ virtual/pkgconfig
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"