summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Mail-DKIM
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Mail-DKIM')
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-0.400.0.ebuild32
-rw-r--r--dev-perl/Mail-DKIM/Manifest1
-rw-r--r--dev-perl/Mail-DKIM/metadata.xml38
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-0.400.0.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-0.400.0.ebuild
new file mode 100644
index 000000000000..36005020f051
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-0.400.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JASLONG
+MODULE_VERSION=0.40
+inherit perl-module
+
+DESCRIPTION="Mail::DKIM - Signs/verifies Internet mail using DKIM message signatures"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-perl/Crypt-OpenSSL-RSA-0.24
+ virtual/perl-Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/Net-DNS
+ dev-perl/MailTools"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+src_test(){
+ # disable online tests
+ for test in policy public_key verifier ; do
+ mv "${S}"/t/${test}.t{,.disable}
+ done
+ perl-module_src_test
+}
diff --git a/dev-perl/Mail-DKIM/Manifest b/dev-perl/Mail-DKIM/Manifest
new file mode 100644
index 000000000000..be43d2c1ce5b
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Manifest
@@ -0,0 +1 @@
+DIST Mail-DKIM-0.40.tar.gz 95186 SHA256 3c5ea0c3a2028a5a2c3b64bbcd6bd9de6a5fa5ee4e16046dd8875c4796aaa6f1 SHA512 27f10a96f70e56e69f55e5077fb93f29f66d8e7a21846c8fb518403af915f85ac06f0968e6002fa2dc7090746e14a5a7bd973e46bb1d52e4200c3c120cd2e924 WHIRLPOOL 81b33d77b81d76a38e19fef5f2c9e17518eff42ebee736fef0496fd646242f06ae2f9f273ea803337e243d3c2d258e660b70a8383df7fafe228215e38ab7c780
diff --git a/dev-perl/Mail-DKIM/metadata.xml b/dev-perl/Mail-DKIM/metadata.xml
new file mode 100644
index 000000000000..fcf756df9b0c
--- /dev/null
+++ b/dev-perl/Mail-DKIM/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Mail-DKIM</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Algorithm::Base</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Algorithm::dk_rsa_sha1</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Algorithm::rsa_sha1</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Algorithm::rsa_sha256</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::AuthorDomainPolicy</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::Base</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::DkCommon</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::DkimCommon</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::dk_nofws</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::dk_simple</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::nowsp</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::relaxed</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Canonicalization::simple</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Common</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::DNS</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::DkPolicy</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::DkSignature</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::DkimPolicy</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Key</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::KeyValueList</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::MessageParser</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Policy</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::PrivateKey</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::PublicKey</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Signature</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Signer</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::SignerPolicy</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::TextWrap</remote-id>
+ <remote-id type="cpan-module">Mail::DKIM::Verifier</remote-id>
+ </upstream>
+</pkgmetadata>