summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-15 07:08:06 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-15 07:08:06 +1200
commit537446945c26eac34902bdeef88306b63459936f (patch)
treeae6f30ceeeaf662a97e0aa1333a7f4e12c8bb50a /dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild
parentdev-perl/Exception-Base: -r bump for EAPI7 + minor fixes (diff)
downloadgentoo-537446945c26eac34902bdeef88306b63459936f.tar.gz
gentoo-537446945c26eac34902bdeef88306b63459936f.tar.bz2
gentoo-537446945c26eac34902bdeef88306b63459936f.zip
dev-perl/Exception-Class: Bump to version 1.440.0
- EAPI7 Upstream: - $exception->throw( ... ) now accepts `frame_filter`,`filter_frames_early`, and `skip_frames` to pass to Devel::StackTrace constructor. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild
new file mode 100644
index 000000000000..5cea483224a3
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.440.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.44
+DIST_EXAMPLES=("bench/*")
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"