summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-02 20:36:12 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-02 20:42:48 +0100
commitd334334850afb8f62fdf2cc7b2ee9c6264e69b41 (patch)
treebfb97fd3c2f044d09821e2d4011f8d2540844279 /dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
parentdev-perl/DBD-SQLite: Remove old (diff)
downloadgentoo-d334334850afb8f62fdf2cc7b2ee9c6264e69b41.tar.gz
gentoo-d334334850afb8f62fdf2cc7b2ee9c6264e69b41.tar.bz2
gentoo-d334334850afb8f62fdf2cc7b2ee9c6264e69b41.zip
dev-perl/DBD-Pg: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
new file mode 100644
index 000000000000..4fac94093d30
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=TURNSTEP
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+# testcases require a local database with an
+# open password for the postgres user.
+DIST_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}