summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:47:04 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:41 +1100
commit68d6f8068733cb9cb12f9a51f4decb433cc5dc24 (patch)
tree60ed28d3065d81d76d19955aa674119e705e63f0 /dev-ml/ppx_sexp_conv
parentdev-ml/ppx_pipebang: Bump to 0.14.0 (diff)
downloadgentoo-68d6f8068733cb9cb12f9a51f4decb433cc5dc24.tar.gz
gentoo-68d6f8068733cb9cb12f9a51f4decb433cc5dc24.tar.bz2
gentoo-68d6f8068733cb9cb12f9a51f4decb433cc5dc24.zip
dev-ml/ppx_sexp_conv: Bump to 0.14.1
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_sexp_conv')
-rw-r--r--dev-ml/ppx_sexp_conv/Manifest1
-rw-r--r--dev-ml/ppx_sexp_conv/files/ppx_sexp_conv-0.14.1-ppxlib-0.18.0.patch41
-rw-r--r--dev-ml/ppx_sexp_conv/metadata.xml5
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.1.ebuild26
4 files changed, 72 insertions, 1 deletions
diff --git a/dev-ml/ppx_sexp_conv/Manifest b/dev-ml/ppx_sexp_conv/Manifest
index c2d417ec8f51..3c751982c3d5 100644
--- a/dev-ml/ppx_sexp_conv/Manifest
+++ b/dev-ml/ppx_sexp_conv/Manifest
@@ -1 +1,2 @@
+DIST ppx_sexp_conv-0.14.1.tar.gz 49857 BLAKE2B ede55963d995917bd0c4a1464b58f8584ec6be4793df706fd3be96670fe685aba82459f9a1e4c6117c594953a3f23c502cc609f1069d482d24278baf7ed87ed5 SHA512 5018abe07300f67cb2c8b8cd8242403a91ac6b7fda13fe43060b3b09635082a7ad45858c7c6442a5fcae2b6d7d398a03eec16cfcbc5fd59f7f3f5c5fd1ad56f9
DIST ppx_sexp_conv-0.9.0.tar.gz 28000 BLAKE2B 2536d3ddbd4ee83baf9eade208983ce9856318079e29da9858838c985b904a7e2e1c6e3ea06bd1360cc17e619f1e952634554e89b294dd00981934679b384c3f SHA512 af3d28a3cdb7c796549a2598c218f69a69d58da715ef2d16077c3adeb22823fa7bec6bc0d8cb6caaf2a0adb56dfcb39d667975959251fb310b69d6abe8302845
diff --git a/dev-ml/ppx_sexp_conv/files/ppx_sexp_conv-0.14.1-ppxlib-0.18.0.patch b/dev-ml/ppx_sexp_conv/files/ppx_sexp_conv-0.14.1-ppxlib-0.18.0.patch
new file mode 100644
index 000000000000..48004a4f26e2
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/files/ppx_sexp_conv-0.14.1-ppxlib-0.18.0.patch
@@ -0,0 +1,41 @@
+commit 13e9b27f5f9550b825128f8cd1f31d20dc8fa91b (HEAD, origin/upgrade-ppxlib-0.18.0)
+Author: Nathan Rebours <nathan.p.rebours@gmail.com>
+Date: Mon Oct 5 17:33:56 2020 +0200
+
+ Make ppx_sexp_conv compatible with ppxlib.0.18.0
+
+ ppxlib.0.18.0 upgrades to the 4.11 AST which results in a change
+ in string constants representation. This PR makes ppx_sexp_conv
+ compatible with the latest ppxlib.
+
+ You might want for the actual release of ppxlib.0.18.0 before merging
+ this!
+
+ Signed-off-by: Nathan Rebours <nathan.p.rebours@gmail.com>
+
+diff --git a/expander/sexp_grammar_lifter.ml b/expander/sexp_grammar_lifter.ml
+index 05005bf..17f1e73 100644
+--- a/expander/sexp_grammar_lifter.ml
++++ b/expander/sexp_grammar_lifter.ml
+@@ -28,7 +28,7 @@ type atom = Atom.t
+ type var_name = Sexp.Private.Raw_grammar.var_name
+ type type_name = Sexp.Private.Raw_grammar.type_name
+
+-let lift_string ~loc s = pexp_constant ~loc (Pconst_string (s, None))
++let lift_string ~loc s = pexp_constant ~loc (Pconst_string (s, loc, None))
+ let lift_var_name = lift_string
+ let lift_type_name = lift_string
+
+diff --git a/ppx_sexp_conv.opam b/ppx_sexp_conv.opam
+index 06fd03e..05c4182 100644
+--- a/ppx_sexp_conv.opam
++++ b/ppx_sexp_conv.opam
+@@ -15,7 +15,7 @@ depends: [
+ "base" {>= "v0.14" & < "v0.15"}
+ "sexplib0" {>= "v0.14" & < "v0.15"}
+ "dune" {>= "2.0.0"}
+- "ppxlib" {>= "0.11.0"}
++ "ppxlib" {>= "0.18.0"}
+ ]
+ synopsis: "[@@deriving] plugin to generate S-expression conversion functions"
+ description: "
diff --git a/dev-ml/ppx_sexp_conv/metadata.xml b/dev-ml/ppx_sexp_conv/metadata.xml
index 0ff7a80359e7..49e0dac594b0 100644
--- a/dev-ml/ppx_sexp_conv/metadata.xml
+++ b/dev-ml/ppx_sexp_conv/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
<upstream>
<remote-id type="github">janestreet/ppx_sexp_conv</remote-id>
</upstream>
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.1.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.1.ebuild
new file mode 100644
index 000000000000..a8e0f48c7c3c
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ >=dev-ml/ppxlib-0.18.0:=
+ dev-ml/ocaml-compiler-libs:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ppxlib-0.18.0.patch )