summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:21:06 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-14 19:24:28 +0200
commitb571568c6c91ccb431862e7a7a2f89fc55063dc3 (patch)
treeb6b9bce494aec7df36adb1101d1be0ea4bbcfb79 /dev-ml/ppx_jane
parentdev-ml/ppx_bin_prot: add 0.17.0 (diff)
downloadgentoo-b571568c6c91ccb431862e7a7a2f89fc55063dc3.tar.gz
gentoo-b571568c6c91ccb431862e7a7a2f89fc55063dc3.tar.bz2
gentoo-b571568c6c91ccb431862e7a7a2f89fc55063dc3.zip
dev-ml/ppx_jane: add 0.17.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_jane')
-rw-r--r--dev-ml/ppx_jane/Manifest1
-rw-r--r--dev-ml/ppx_jane/ppx_jane-0.17.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/ppx_jane/Manifest b/dev-ml/ppx_jane/Manifest
index 0ac1b11b414c..bb214b12f0f3 100644
--- a/dev-ml/ppx_jane/Manifest
+++ b/dev-ml/ppx_jane/Manifest
@@ -1,3 +1,4 @@
DIST ppx_jane-0.14.0.tar.gz 4593 BLAKE2B 787fc0701ba0361446cb210c23469881da8fbab28460262a7bdca8723af158ed8deeb4597a31c8d89a4d44e5263c74e0ebc504b83827e0a34870a503b2ea9053 SHA512 b51bef2330ebb8d361b3f856a0526a5290664b68fa56a02de7020b0e27aaf5a378f1b22fc9a24007bfc812af67eb79343b2bdc3ca550108393323b99e29c623d
DIST ppx_jane-0.15.0.tar.gz 4647 BLAKE2B c8916e7327301a2dc54b36cc29ad61f3ef016aac2f07dd8c1421a84b144b406e9b189e229680f700efaf2138c508f30e0d132dcf726165ac60ad3120f67549d7 SHA512 e594a0caea66e0f976615b2a1db50aad89389888678d9ec7c023b2adb3211817a841a5065de9a65956bde0cb6088ce1b0b3afed6b57b618b9b50e5c07684e3fa
DIST ppx_jane-0.16.0.tar.gz 4688 BLAKE2B 46d2b4c6c7924fc6ff2bf4cae2171dd022a1ef51d8354c5393884a121cbeda001157650843c4409a22491a16445d36e374fe159cb826839e2b2a6950c0606d2c SHA512 8bb5997eb33a2f8ef7ec88d5a31c03828cc6f7070641463ad5af318b865fe8638b1affa359db07e8880364598b43ad19621882cf4c3311e38cf0638a59271652
+DIST ppx_jane-0.17.0.tar.gz 4497 BLAKE2B cfa5f81e444fa98f89ed1c7488db7d91473266326b9820b5c0647f09930dd6694d2d5d0b5e23640ac42a6d7df2902ce748337444c2758fff1b8c8d3a204d1e20 SHA512 5992b017f49b642eee31a7ae921e49d06f0dd88f20062cb8fbdc64910f839a7e86ce9128e9baf48a5fb9e3bc2c0fb044434a5a532bf7d7afbc41687f320c6b23
diff --git a/dev-ml/ppx_jane/ppx_jane-0.17.0.ebuild b/dev-ml/ppx_jane/ppx_jane-0.17.0.ebuild
new file mode 100644
index 000000000000..773e5970e53a
--- /dev/null
+++ b/dev-ml/ppx_jane/ppx_jane-0.17.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard Jane Street ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_jane"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base_quickcheck:${SLOT}[ocamlopt?]
+ dev-ml/ppx_assert:${SLOT}[ocamlopt?]
+ dev-ml/ppx_base:${SLOT}[ocamlopt?]
+ dev-ml/ppx_bench:${SLOT}[ocamlopt?]
+ dev-ml/ppx_bin_prot:${SLOT}[ocamlopt?]
+ dev-ml/ppx_custom_printf:=[ocamlopt?]
+ dev-ml/ppx_disable_unused_warnings:${SLOT}[ocamlopt?]
+ dev-ml/ppx_expect:${SLOT}[ocamlopt?]
+ dev-ml/ppx_fields_conv:${SLOT}[ocamlopt?]
+ dev-ml/ppx_fixed_literal:${SLOT}[ocamlopt?]
+ dev-ml/ppx_here:${SLOT}[ocamlopt?]
+ dev-ml/ppx_ignore_instrumentation:${SLOT}[ocamlopt?]
+ dev-ml/ppx_inline_test:${SLOT}[ocamlopt?]
+ dev-ml/ppx_let:${SLOT}[ocamlopt?]
+ dev-ml/ppx_log:${SLOT}[ocamlopt?]
+ dev-ml/ppx_module_timer:${SLOT}[ocamlopt?]
+ dev-ml/ppx_optional:${SLOT}[ocamlopt?]
+ dev-ml/ppx_pipebang:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_message:${SLOT}[ocamlopt?]
+ dev-ml/ppx_sexp_value:${SLOT}[ocamlopt?]
+ dev-ml/ppx_stable:${SLOT}[ocamlopt?]
+ dev-ml/ppx_stable_witness:${SLOT}[ocamlopt?]
+ dev-ml/ppx_string:${SLOT}
+ dev-ml/ppx_string_conv:${SLOT}
+ dev-ml/ppx_tydi:${SLOT}
+ dev-ml/ppx_typerep_conv:${SLOT}
+ dev-ml/ppx_variants_conv:${SLOT}
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"