summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-10-01 20:49:12 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-10-01 20:49:12 +0200
commit38ae9203ad05bc80e0172feaf162a9f6e8d92ad5 (patch)
tree4894d15100950033248dcd9ba58cffb9d173e561 /dev-ml/opam-repository
parentdev-ml/lwt: build with ocaml-4.12 (diff)
downloadgentoo-38ae9203ad05bc80e0172feaf162a9f6e8d92ad5.tar.gz
gentoo-38ae9203ad05bc80e0172feaf162a9f6e8d92ad5.tar.bz2
gentoo-38ae9203ad05bc80e0172feaf162a9f6e8d92ad5.zip
dev-ml/opam-repository: build with ocaml-4.12
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam-repository')
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.8-r1.ebuild4
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.8.ebuild1
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.9.ebuild4
3 files changed, 9 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/opam-repository-2.0.8-r1.ebuild b/dev-ml/opam-repository/opam-repository-2.0.8-r1.ebuild
index 77365ae1bced..7715c1f74d1a 100644
--- a/dev-ml/opam-repository/opam-repository-2.0.8-r1.ebuild
+++ b/dev-ml/opam-repository/opam-repository-2.0.8-r1.ebuild
@@ -37,3 +37,7 @@ src_prepare() {
(flags (:standard -warn-error -3-9-33))))
EOF
}
+
+src_compile() {
+ dune build @install --profile release || die
+}
diff --git a/dev-ml/opam-repository/opam-repository-2.0.8.ebuild b/dev-ml/opam-repository/opam-repository-2.0.8.ebuild
index 632b71026c65..4bfd5662c257 100644
--- a/dev-ml/opam-repository/opam-repository-2.0.8.ebuild
+++ b/dev-ml/opam-repository/opam-repository-2.0.8.ebuild
@@ -17,6 +17,7 @@ IUSE="+ocamlopt"
RESTRICT="test"
RDEPEND="
+ <dev-lang/ocaml-4.12
~dev-ml/opam-format-${PV}:=
dev-ml/re:=
dev-ml/dose3:=
diff --git a/dev-ml/opam-repository/opam-repository-2.0.9.ebuild b/dev-ml/opam-repository/opam-repository-2.0.9.ebuild
index 77365ae1bced..7715c1f74d1a 100644
--- a/dev-ml/opam-repository/opam-repository-2.0.9.ebuild
+++ b/dev-ml/opam-repository/opam-repository-2.0.9.ebuild
@@ -37,3 +37,7 @@ src_prepare() {
(flags (:standard -warn-error -3-9-33))))
EOF
}
+
+src_compile() {
+ dune build @install --profile release || die
+}