summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-18 21:26:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-18 22:09:53 +0200
commit5012ff224c8252f414028f986b9bc5a9bb835504 (patch)
treeaeb5cf5ce5a936cf5f0dfaf7dea5bfa5d187c8b3 /dev-ml/base/base-0.9.2.ebuild
parentdev-ml/ppx_driver: bump to 0.9.1 (diff)
downloadgentoo-5012ff224c8252f414028f986b9bc5a9bb835504.tar.gz
gentoo-5012ff224c8252f414028f986b9bc5a9bb835504.tar.bz2
gentoo-5012ff224c8252f414028f986b9bc5a9bb835504.zip
dev-ml/base: bump to 0.9.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/base/base-0.9.2.ebuild')
-rw-r--r--dev-ml/base/base-0.9.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/base/base-0.9.2.ebuild b/dev-ml/base/base-0.9.2.ebuild
new file mode 100644
index 000000000000..b6a07e3d5965
--- /dev/null
+++ b/dev-ml/base/base-0.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Standard library for OCaml"
+HOMEPAGE="https://github.com/janestreet/base"
+SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ <dev-ml/sexplib-100
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc ROADMAP.md README.org
+}