summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-22 21:40:32 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 22:00:10 +0200
commitfd0f1d9de33d11fdb454eaf4ff41e6cdafcbe3f0 (patch)
tree5d3223526d3f9d34bebf305afc3959ca690085b0 /dev-lua
parentdev-lua/luadbi: drop 0.7.2-r2 (diff)
downloadgentoo-fd0f1d9de33d11fdb454eaf4ff41e6cdafcbe3f0.tar.gz
gentoo-fd0f1d9de33d11fdb454eaf4ff41e6cdafcbe3f0.tar.bz2
gentoo-fd0f1d9de33d11fdb454eaf4ff41e6cdafcbe3f0.zip
dev-lua/lualdap: drop 1.3.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lualdap/Manifest1
-rw-r--r--dev-lua/lualdap/lualdap-1.3.1.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-lua/lualdap/Manifest b/dev-lua/lualdap/Manifest
index eaf86455ed5a..09c3b7458383 100644
--- a/dev-lua/lualdap/Manifest
+++ b/dev-lua/lualdap/Manifest
@@ -1,2 +1 @@
-DIST lualdap-1.3.1.tar.gz 82290 BLAKE2B 8436f1b3cf6497a3aea19de74a2e06bf2bb9ba4951d7357584c5b29a4d37ea2c5d4877d6ea3d44fca42d19207366abdf6a017ce1953d283a7bc243d230081077 SHA512 29d622ecf63214ac26ade71478c383e4f1b7468097bf19b99b8209b3f6cbb2078298a149d64ba8a7ca4abe97aa45550982792fa4ac0a8014f7daf709fe725e9f
DIST lualdap-1.4.0.tar.gz 83205 BLAKE2B 8e56cbf8f772fd4bac3e4d545741d51adc447cdc00a4ccaa390af3ddbd035de9fe7b0a652ce71da869f74ba241c51f2a63835f2f200e9454a058e123d4acbf5f SHA512 92d6cb81adfb9fc21ba21d6e765f70c1eb0e30bd04d5fabc2bec2a9e22850c5ab1586bf866f01a871e72a705de93d61be2545edf3d9b25011f74f2a5c4e46d32
diff --git a/dev-lua/lualdap/lualdap-1.3.1.ebuild b/dev-lua/lualdap/lualdap-1.3.1.ebuild
deleted file mode 100644
index 36fc9c5c764e..000000000000
--- a/dev-lua/lualdap/lualdap-1.3.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A lua binding for the OpenLDAP client libraries"
-HOMEPAGE="https://github.com/lualdap/lualdap"
-SRC_URI="https://github.com/lualdap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="
- net-nds/openldap:=
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( ${RDEPEND} )
-"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LBER_LIBDIR=/usr/$(get_libdir)"
- "LDAP_LIBDIR=/usr/$(get_libdir)"
- "LUA_INCDIR=$(lua_get_include_dir)"
- "LUA_LIBDIR=/usr/$(get_libdir)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd || die
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_test() {
- pushd "${BUILD_DIR}" || die
- LUA_CPATH="./src/?.so" ${ELUA} tests/test.lua || die
- popd || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- # Workaround, as 'make install' does not create this directory
- dodir "$(lua_get_cmod_dir)"
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "INST_LIBDIR=$(lua_get_cmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd || die
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}