summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-10-23 12:21:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-10-23 12:24:07 +0200
commitec5b12f0684b6274726ef090465ee2167c7b146c (patch)
tree2b4a18837d2cb16fb1c4685def52a3edc9139274 /dev-lua
parentdev-ruby/ffi: destabilize 1.15.5-r1 (diff)
downloadgentoo-ec5b12f0684b6274726ef090465ee2167c7b146c.tar.gz
gentoo-ec5b12f0684b6274726ef090465ee2167c7b146c.tar.bz2
gentoo-ec5b12f0684b6274726ef090465ee2167c7b146c.zip
dev-lua/say: add 1.4.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/say/Manifest1
-rw-r--r--dev-lua/say/metadata.xml2
-rw-r--r--dev-lua/say/say-1.4.1.ebuild46
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-lua/say/Manifest b/dev-lua/say/Manifest
index c196908b1e38..31dc07a30a59 100644
--- a/dev-lua/say/Manifest
+++ b/dev-lua/say/Manifest
@@ -1 +1,2 @@
DIST say-1.3_p1.tar.gz 3667 BLAKE2B bd99687a71129c5038749b0a2ea48411a411cf05559793cc0c4802a5b7aa620fbf4fd15ed9ab661b33c7b9f94468aaf9e292d177aca4d1c7cd29009601d015f0 SHA512 8d4a360bf0731c2a70c23edb9e6e81cab1e7d9b861aa35103a5c6e521633410860d76c46dc2ea62a06ac8ab3b522bc71c11143d6fe7e26e7fa24dd3f5ea1e5f6
+DIST say-1.4.1.tar.gz 6091 BLAKE2B 59280a9d8e95f1f759c59a4886f864046ff65db035652acec0c9c32eda000ed8eda74385769bc6b0946262a3695db857848ca4b844a8a1626949c1b5bf273dab SHA512 a6c3477859615d7ae0677ac7aa0cefe8bf6f43424812062b4a06145017952b176801431c5be920cb67f52c07cc3d374e8a6714233e2252a2bb6b7ed4c3e32f90
diff --git a/dev-lua/say/metadata.xml b/dev-lua/say/metadata.xml
index be04c7182c17..f476c828a2cd 100644
--- a/dev-lua/say/metadata.xml
+++ b/dev-lua/say/metadata.xml
@@ -11,6 +11,6 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">Olivine-Labs/say</remote-id>
+ <remote-id type="github">lunarmodules/say</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-lua/say/say-1.4.1.ebuild b/dev-lua/say/say-1.4.1.ebuild
new file mode 100644
index 000000000000..b17a4c9fa4d1
--- /dev/null
+++ b/dev-lua/say/say-1.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="https://github.com/lunarmodules/say"
+SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-lua/busted[${LUA_USEDEP}] )
+ ${RDEPEND}
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/say
+ doins src/say/init.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}