summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-21 23:17:22 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-21 23:23:07 +0200
commit65608a8716d8babbb2b8ba0a252b3e4a8c358248 (patch)
treefca6a7db5f5d2ed365b6ecd942d786c61ead7013 /dev-lua
parentgames-server/bedrock-server: add 1.18.30.04 (diff)
downloadgentoo-65608a8716d8babbb2b8ba0a252b3e4a8c358248.tar.gz
gentoo-65608a8716d8babbb2b8ba0a252b3e4a8c358248.tar.bz2
gentoo-65608a8716d8babbb2b8ba0a252b3e4a8c358248.zip
dev-lua/readline: add 3.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/readline/Manifest1
-rw-r--r--dev-lua/readline/readline-3.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-lua/readline/Manifest b/dev-lua/readline/Manifest
index 1e2e13b8dfb3..8e0008d1da86 100644
--- a/dev-lua/readline/Manifest
+++ b/dev-lua/readline/Manifest
@@ -1 +1,2 @@
DIST lua-readline-3.0.tar.gz 15675 BLAKE2B 877b50cdf05610eb54fcec6063368206d68b0571e70c28abd6bdf20e0533ae76809a18f3b7cbefc79185544966e2838c8ea95b30bc5821c31547026ee621d1f0 SHA512 7fc9b1b2b03909cd8ebccc539fa8c37a823c70728671dc09c7cec0641625a59ed3c8b7045635e53719d32046437e638193cb1055a94a3d635fb50efb199d213a
+DIST lua-readline-3.1.tar.gz 16114 BLAKE2B 372bc61573b20c8ebf66bb684624dde9d5ce7868543294450ef3d47bba5a042c5d7f4262366f2de2db8d3d92bbf7fb4895d29577af34307d7b145e6f913ec957 SHA512 d3bee61b6c876e96d2c1097e29862a3f16d1e666b1087e58899f59a3115f9af31793492edfcc3f3802565f98f276960d382a89c0b6cfb1d54acfd37ad006b74b
diff --git a/dev-lua/readline/readline-3.1.ebuild b/dev-lua/readline/readline-3.1.ebuild
new file mode 100644
index 000000000000..813f6f10ba3e
--- /dev/null
+++ b/dev-lua/readline/readline-3.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A simple interface to the readline and history libraries"
+HOMEPAGE="https://pjb.com.au/comp/lua/readline.html"
+SRC_URI="https://pjb.com.au/comp/lua/${P}.tar.gz -> lua-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Tests are interactive
+RESTRICT="test"
+
+RDEPEND="
+ dev-lua/luaposix
+ sys-libs/readline:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local compiler=(
+ "$(tc-getCC)"
+ "${CFLAGS}"
+ "-fPIC"
+ "$(lua_get_CFLAGS)"
+ "-c C-readline.c"
+ "-o C-readline.o"
+ )
+ einfo "${compiler[@]}"
+ ${compiler[@]} || die
+
+ local linker=(
+ "$(tc-getCC)"
+ "-shared"
+ "${LDFLAGS}"
+ "$($(tc-getPKG_CONFIG) --libs readline)"
+ "-o C-readline.so"
+ "C-readline.o"
+ )
+ einfo "${linker[@]}"
+ ${linker[@]} || die
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+ LUA_CPATH="./?.so;${ESYSROOT}/usr/$(get_libdir)/lua/$(ver_cut 1-2 $(lua_get_version))/?.so" ${ELUA} test/test_rl.lua || die
+ popd || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ insinto "$(lua_get_cmod_dir)"
+ doins C-readline.so
+
+ insinto "$(lua_get_lmod_dir)"
+ doins readline.lua
+
+ popd || die
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ docinto html
+ dodoc doc/readline.html
+}