summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:35:03 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2015-12-17 23:35:03 +0100
commit813b273e70add1c1479759913dd95b4786f74350 (patch)
tree836d6070dff2f27c1a3f69a63308a6592a29d8d5 /dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
parentdev-lisp/cl-ppcre: bump to version 2.0.11 (diff)
downloadgentoo-813b273e70add1c1479759913dd95b4786f74350.tar.gz
gentoo-813b273e70add1c1479759913dd95b4786f74350.tar.bz2
gentoo-813b273e70add1c1479759913dd95b4786f74350.zip
dev-lisp/cl-ppcre-unicode: add from lisp overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild')
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
new file mode 100644
index 000000000000..9cb11ed36495
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit common-lisp-3
+
+MY_P="v${PV}"
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+ http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/${MY_P}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lisp/cl-ppcre-${PV}*
+ dev-lisp/cl-unicode"
+
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+src_install() {
+ common-lisp-install-sources ${PN}/ test/unicode*
+ common-lisp-install-asdf ${PN}
+}