summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-06 08:37:57 +0100
committerSam James <sam@gentoo.org>2022-05-06 08:47:17 +0100
commitff6e2d8fc9c2e4a5a2407ae69a7c1c7661b07823 (patch)
tree51c7a97ea414a76426b1a820bccde11f6cfabbac /dev-libs
parentdev-python/boolean-py: Bump to 4.0 (diff)
downloadgentoo-ff6e2d8fc9c2e4a5a2407ae69a7c1c7661b07823.tar.gz
gentoo-ff6e2d8fc9c2e4a5a2407ae69a7c1c7661b07823.tar.bz2
gentoo-ff6e2d8fc9c2e4a5a2407ae69a7c1c7661b07823.zip
dev-libs/pkcs11-helper: add 1.29.0
Closes: https://bugs.gentoo.org/805047 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pkcs11-helper/Manifest1
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.29.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/Manifest b/dev-libs/pkcs11-helper/Manifest
index fa7ff1622a81..97abc0d26b60 100644
--- a/dev-libs/pkcs11-helper/Manifest
+++ b/dev-libs/pkcs11-helper/Manifest
@@ -1 +1,2 @@
DIST pkcs11-helper-1.27.0.tar.bz2 422425 BLAKE2B a9fd7ef04dce1abbae57b09a12b4be560465ae0cf2910443332882967d00b6380c62944820aa9580e101459d1c35edaae68cd7abbafa308a8b152921ac32f04c SHA512 5799342cb755dae8b7ba0880d652e9d4b4f1e52a74043015e1185e1e059326cb2689bb51957db98060ac2257dee34e2f047dcf3d52ad59fd49b91fedcfc5332b
+DIST pkcs11-helper-1.29.0.tar.bz2 422549 BLAKE2B fec72ac82f1545fc50f80b5b28db12906df32fa3bc65f80541d8bee7f1d1c8062f1f0516344237424022c01d4f390e8a72e3e0262250f3b6c51df92c768d81ee SHA512 c530f5a4b5826a02bfe787a1293a7595d5a0d6348daa16675bd10c6d6734b1f24a3cc73b5b89433cf1edf8815f8b7298fdfd1ed686f096bb5edfb425e9430eb2
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0.ebuild
new file mode 100644
index 000000000000..9d5bdc147bbc
--- /dev/null
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.29.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PKCS#11 helper library"
+HOMEPAGE="https://github.com/OpenSC/pkcs11-helper"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc gnutls nss"
+
+RDEPEND=">=dev-libs/openssl-0.9.7:=
+ gnutls? ( >=net-libs/gnutls-1.4.4:= )
+ nss? ( dev-libs/nss )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+src_configure() {
+ econf \
+ --disable-crypto-engine-polarssl \
+ --disable-crypto-engine-mbedtls \
+ $(use_enable doc) \
+ $(use_enable gnutls crypto-engine-gnutls) \
+ $(use_enable nss crypto-engine-nss)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}