summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 18:08:04 +0100
committerSam James <sam@gentoo.org>2023-05-29 19:18:52 +0100
commite5c74fd99168ba853a2a93b03ae36eba567ae202 (patch)
tree7760d4be551c54e0455a6c4cad416060dd72ebe4 /dev-libs
parentdev-lang/perl: drop dead prefix targets (diff)
downloadgentoo-e5c74fd99168ba853a2a93b03ae36eba567ae202.tar.gz
gentoo-e5c74fd99168ba853a2a93b03ae36eba567ae202.tar.bz2
gentoo-e5c74fd99168ba853a2a93b03ae36eba567ae202.zip
dev-libs/apr: drop dead prefix targets
The removal was already done, so this is just cleanup afterwards. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/apr-1.7.2-r1.ebuild35
-rw-r--r--dev-libs/apr/apr-1.7.2.ebuild35
-rw-r--r--dev-libs/apr/apr-1.7.3.ebuild36
-rw-r--r--dev-libs/apr/apr-1.7.4.ebuild35
-rw-r--r--dev-libs/apr/files/apr-1.5.0-mint.patch22
5 files changed, 24 insertions, 139 deletions
diff --git a/dev-libs/apr/apr-1.7.2-r1.ebuild b/dev-libs/apr/apr-1.7.2-r1.ebuild
index 7986ed4088df..e1c446e9551f 100644
--- a/dev-libs/apr/apr-1.7.2-r1.ebuild
+++ b/dev-libs/apr/apr-1.7.2-r1.ebuild
@@ -31,7 +31,6 @@ BDEPEND="
DOCS=( CHANGES NOTICE README )
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-mint.patch
"${FILESDIR}"/${PN}-1.6.3-skip-known-failing-tests.patch
"${FILESDIR}"/${PN}-1.7.2-libtool.patch
"${FILESDIR}"/${PN}-1.7.2-sysroot.patch # bug #385775
@@ -96,38 +95,16 @@ src_configure() {
if use urandom; then
myconf+=( --with-devrandom=/dev/urandom )
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, apr detects this.
else
myconf+=( --with-devrandom=/dev/random )
fi
- # shl_load does not search runpath, but hpux11 supports dlopen
- if [[ ${CHOST} == *-hpux11* ]]; then
- myconf+=( --enable-dso=dlfcn )
- elif [[ ${CHOST} == *-solaris2.10 ]]; then
- local atomic_contents=$(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h)
-
- case "${atomic_contents}" in
- *atomic_cas_ptr*)
- ;;
- *)
- local patch_id=$([[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885)
-
- elog "You do not have Solaris Patch ID ${patch_id} (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
-
- myconf+=( --disable-nonportable-atomics )
- ;;
- esac
- else
- if use ppc || use sparc || use mips; then
- # Avoid libapr containing undefined references (underlinked)
- # undefined reference to `__sync_val_compare_and_swap_8'
- # (May be possible to fix via libatomic linkage in future?)
- # bug #740464
- myconf+=( --disable-nonportable-atomics )
- fi
+ if use ppc || use sparc || use mips; then
+ # Avoid libapr containing undefined references (underlinked)
+ # undefined reference to `__sync_val_compare_and_swap_8'
+ # (May be possible to fix via libatomic linkage in future?)
+ # bug #740464
+ myconf+=( --disable-nonportable-atomics )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/apr/apr-1.7.2.ebuild b/dev-libs/apr/apr-1.7.2.ebuild
index 13fff2505e42..2bac56d69761 100644
--- a/dev-libs/apr/apr-1.7.2.ebuild
+++ b/dev-libs/apr/apr-1.7.2.ebuild
@@ -31,7 +31,6 @@ BDEPEND="
DOCS=( CHANGES NOTICE README )
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-mint.patch
"${FILESDIR}"/${PN}-1.6.3-skip-known-failing-tests.patch
"${FILESDIR}"/${PN}-1.7.2-libtool.patch
"${FILESDIR}"/${PN}-1.7.2-sysroot.patch # bug #385775
@@ -95,38 +94,16 @@ src_configure() {
if use urandom; then
myconf+=( --with-devrandom=/dev/urandom )
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, apr detects this.
else
myconf+=( --with-devrandom=/dev/random )
fi
- # shl_load does not search runpath, but hpux11 supports dlopen
- if [[ ${CHOST} == *-hpux11* ]]; then
- myconf+=( --enable-dso=dlfcn )
- elif [[ ${CHOST} == *-solaris2.10 ]]; then
- local atomic_contents=$(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h)
-
- case "${atomic_contents}" in
- *atomic_cas_ptr*)
- ;;
- *)
- local patch_id=$([[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885)
-
- elog "You do not have Solaris Patch ID ${patch_id} (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
-
- myconf+=( --disable-nonportable-atomics )
- ;;
- esac
- else
- if use ppc || use sparc || use mips; then
- # Avoid libapr containing undefined references (underlinked)
- # undefined reference to `__sync_val_compare_and_swap_8'
- # (May be possible to fix via libatomic linkage in future?)
- # bug #740464
- myconf+=( --disable-nonportable-atomics )
- fi
+ if use ppc || use sparc || use mips; then
+ # Avoid libapr containing undefined references (underlinked)
+ # undefined reference to `__sync_val_compare_and_swap_8'
+ # (May be possible to fix via libatomic linkage in future?)
+ # bug #740464
+ myconf+=( --disable-nonportable-atomics )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/apr/apr-1.7.3.ebuild b/dev-libs/apr/apr-1.7.3.ebuild
index 7986ed4088df..3dc1fa16ac8a 100644
--- a/dev-libs/apr/apr-1.7.3.ebuild
+++ b/dev-libs/apr/apr-1.7.3.ebuild
@@ -31,7 +31,6 @@ BDEPEND="
DOCS=( CHANGES NOTICE README )
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-mint.patch
"${FILESDIR}"/${PN}-1.6.3-skip-known-failing-tests.patch
"${FILESDIR}"/${PN}-1.7.2-libtool.patch
"${FILESDIR}"/${PN}-1.7.2-sysroot.patch # bug #385775
@@ -96,38 +95,15 @@ src_configure() {
if use urandom; then
myconf+=( --with-devrandom=/dev/urandom )
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, apr detects this.
- else
myconf+=( --with-devrandom=/dev/random )
fi
- # shl_load does not search runpath, but hpux11 supports dlopen
- if [[ ${CHOST} == *-hpux11* ]]; then
- myconf+=( --enable-dso=dlfcn )
- elif [[ ${CHOST} == *-solaris2.10 ]]; then
- local atomic_contents=$(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h)
-
- case "${atomic_contents}" in
- *atomic_cas_ptr*)
- ;;
- *)
- local patch_id=$([[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885)
-
- elog "You do not have Solaris Patch ID ${patch_id} (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
-
- myconf+=( --disable-nonportable-atomics )
- ;;
- esac
- else
- if use ppc || use sparc || use mips; then
- # Avoid libapr containing undefined references (underlinked)
- # undefined reference to `__sync_val_compare_and_swap_8'
- # (May be possible to fix via libatomic linkage in future?)
- # bug #740464
- myconf+=( --disable-nonportable-atomics )
- fi
+ if use ppc || use sparc || use mips; then
+ # Avoid libapr containing undefined references (underlinked)
+ # undefined reference to `__sync_val_compare_and_swap_8'
+ # (May be possible to fix via libatomic linkage in future?)
+ # bug #740464
+ myconf+=( --disable-nonportable-atomics )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/apr/apr-1.7.4.ebuild b/dev-libs/apr/apr-1.7.4.ebuild
index 727cb2ad663c..e2253cffa218 100644
--- a/dev-libs/apr/apr-1.7.4.ebuild
+++ b/dev-libs/apr/apr-1.7.4.ebuild
@@ -32,7 +32,6 @@ BDEPEND="
DOCS=( CHANGES NOTICE README )
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0-mint.patch
"${FILESDIR}"/${PN}-1.6.3-skip-known-failing-tests.patch
"${FILESDIR}"/${PN}-1.7.2-libtool.patch
"${FILESDIR}"/${PN}-1.7.2-sysroot.patch # bug #385775
@@ -98,38 +97,16 @@ src_configure() {
if use urandom; then
myconf+=( --with-devrandom=/dev/urandom )
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, apr detects this.
else
myconf+=( --with-devrandom=/dev/random )
fi
- # shl_load does not search runpath, but hpux11 supports dlopen
- if [[ ${CHOST} == *-hpux11* ]]; then
- myconf+=( --enable-dso=dlfcn )
- elif [[ ${CHOST} == *-solaris2.10 ]]; then
- local atomic_contents=$(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h)
-
- case "${atomic_contents}" in
- *atomic_cas_ptr*)
- ;;
- *)
- local patch_id=$([[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885)
-
- elog "You do not have Solaris Patch ID ${patch_id} (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
-
- myconf+=( --disable-nonportable-atomics )
- ;;
- esac
- else
- if use ppc || use sparc || use mips; then
- # Avoid libapr containing undefined references (underlinked)
- # undefined reference to `__sync_val_compare_and_swap_8'
- # (May be possible to fix via libatomic linkage in future?)
- # bug #740464
- myconf+=( --disable-nonportable-atomics )
- fi
+ if use ppc || use sparc || use mips; then
+ # Avoid libapr containing undefined references (underlinked)
+ # undefined reference to `__sync_val_compare_and_swap_8'
+ # (May be possible to fix via libatomic linkage in future?)
+ # bug #740464
+ myconf+=( --disable-nonportable-atomics )
fi
econf "${myconf[@]}"
diff --git a/dev-libs/apr/files/apr-1.5.0-mint.patch b/dev-libs/apr/files/apr-1.5.0-mint.patch
deleted file mode 100644
index cfe039e962c6..000000000000
--- a/dev-libs/apr/files/apr-1.5.0-mint.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- apr-1.5.0/build/apr_hints.m4
-+++ apr-1.5.0/build/apr_hints.m4
-@@ -45,6 +45,8 @@
- case "$host" in
- *mint)
- APR_ADDTO(CPPFLAGS, [-DMINT -D_GNU_SOURCE])
-+ apr_cv_pthreads_cflags="none"
-+ apr_cv_pthreads_lib="-lpthread"
- ;;
- *MPE/iX*)
- APR_ADDTO(CPPFLAGS, [-DMPE -D_POSIX_SOURCE -D_SOCKET_SOURCE])
---- apr-1.5.0/build/apr_threads.m4
-+++ apr-1.5.0/build/apr_threads.m4
-@@ -198,7 +198,7 @@
- AC_DEFUN([APR_CHECK_SIGWAIT_ONE_ARG], [
- AC_CACHE_CHECK(whether sigwait takes one argument,ac_cv_sigwait_one_arg,[
- AC_TRY_COMPILE([
--#if defined(__NETBSD__) || defined(DARWIN)
-+#if defined(__NETBSD__) || defined(DARWIN) || defined(MINT)
- /* When using the unproven-pthreads package, we need to pull in this
- * header to get a prototype for sigwait(). Else things will fail later
- * on. XXX Should probably be fixed in the unproven-pthreads package.