summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-06 08:47:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-06 09:18:58 -0400
commitdbe22a49885c9ee183544560687fd90074d4f25d (patch)
treee073a25fff24af7f839caf8cbb0b83762595fa09 /dev-libs
parentx11-terms/kitty-shell-integration: drop 0.33.1, 0.35.0 (diff)
downloadgentoo-dbe22a49885c9ee183544560687fd90074d4f25d.tar.gz
gentoo-dbe22a49885c9ee183544560687fd90074d4f25d.tar.bz2
gentoo-dbe22a49885c9ee183544560687fd90074d4f25d.zip
dev-libs/simde: drop 0.8.0-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/simde/Manifest1
-rw-r--r--dev-libs/simde/files/simde-0.7.6-musl.patch18
-rw-r--r--dev-libs/simde/files/simde-0.8.0-xop.patch28
-rw-r--r--dev-libs/simde/simde-0.8.0-r1.ebuild46
4 files changed, 0 insertions, 93 deletions
diff --git a/dev-libs/simde/Manifest b/dev-libs/simde/Manifest
index 701b574baabc..60d9a387258b 100644
--- a/dev-libs/simde/Manifest
+++ b/dev-libs/simde/Manifest
@@ -1,2 +1 @@
-DIST simde-0.8.0.tar.gz 7455442 BLAKE2B 511f609e2588cc39b45a5a3e7f93648d9651e9e3f90220947b7f559ca6281a0db9f876d0692abf24d63528bb84e0ee49da1a165a16eeb91de84639a100a6527b SHA512 b0667583565ea9e59d18a07c7a3cb46710868c9572663e314278ca2004747e337e34f6b927c9c5d29e161caba8ec0428e5299b6e878e226b9f33597a1584b91d
DIST simde-0.8.2.tar.gz 7468969 BLAKE2B 55824ac6d525de475285b430e96c91d7e7cdf363cb42742e55cc8b6e44e5d59d2e07d59fe37897d4bc2023fca35bd908772e01ba95681a00c8f9464dccb0f742 SHA512 4e42d7140c0afae507773527c6c0c07e6f0cdad59a1d42ebcf4bd223fc9f71e91a2e3db7746aca3c0c5ad2a13333c2322ce1e384c7d699ddfe33bed6f107aec5
diff --git a/dev-libs/simde/files/simde-0.7.6-musl.patch b/dev-libs/simde/files/simde-0.7.6-musl.patch
deleted file mode 100644
index c070f858ea81..000000000000
--- a/dev-libs/simde/files/simde-0.7.6-musl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This workaround patch should be removable when musl implements C23
-functions (technically this isn't a __GLIBC__-only quirk, but used
-due to lack of anything better beside running a build test for it).
-
-https://bugs.gentoo.org/926488
-https://github.com/simd-everywhere/simde/issues/1001
---- a/simde/simde-math.h
-+++ b/simde/simde-math.h
-@@ -1182,3 +1182,3 @@
- #if \
-- (!defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundeven)) || \
-+ (defined (__GLIBC__) && !defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundeven)) || \
- HEDLEY_GCC_VERSION_CHECK(10,0,0)
-@@ -1202,3 +1202,3 @@
- #if \
-- (!defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundevenf)) || \
-+ (defined(__GLIBC__) && !defined(HEDLEY_EMSCRIPTEN_VERSION) && HEDLEY_HAS_BUILTIN(__builtin_roundevenf)) || \
- HEDLEY_GCC_VERSION_CHECK(10,0,0)
diff --git a/dev-libs/simde/files/simde-0.8.0-xop.patch b/dev-libs/simde/files/simde-0.8.0-xop.patch
deleted file mode 100644
index 1fbfc4fd1ef3..000000000000
--- a/dev-libs/simde/files/simde-0.8.0-xop.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://bugs.gentoo.org/926959
-https://github.com/kovidgoyal/kitty/issues/7222
-https://github.com/simd-everywhere/simde/pull/1154
-From: "Michael R. Crusoe" <michael.crusoe@gmail.com>
-Date: Mon, 25 Mar 2024 10:33:22 +0100
-Subject: [PATCH 1/2] x86 xop: fix some native functions
---- a/simde/arm/neon/paddl.h
-+++ b/simde/arm/neon/paddl.h
-@@ -286,7 +286,7 @@ simde_vpaddlq_u16(simde_uint16x8_t a) {
- simde_uint32x4_private r_;
-
- #if defined(SIMDE_X86_XOP_NATIVE)
-- r_.sse_m128i = _mm_haddd_epu16(a_.sse_m128i);
-+ r_.m128i = _mm_haddd_epu16(a_.m128i);
- #elif defined(SIMDE_X86_SSE2_NATIVE)
- r_.m128i =
- _mm_add_epi32(
---- a/simde/x86/xop.h
-+++ b/simde/x86/xop.h
-@@ -3727,7 +3727,7 @@ simde_mm256_permute2_pd (simde__m256d a, simde__m256d b, simde__m256i c, const i
- SIMDE_LCC_REVERT_DEPRECATED_WARNINGS \
- }))
- #else
-- #define simde_mm256_permute2_pd(a, b, c, imm8) simde_undeprecated_mm256_permute2_pd((a), (b), (c), (imm8))
-+ #define simde_mm256_permute2_pd(a, b, c, imm8) _mm256_permute2_pd((a), (b), (c), (imm8))
- #endif
- #endif
- #if defined(SIMDE_X86_XOP_ENABLE_NATIVE_ALIASES)
diff --git a/dev-libs/simde/simde-0.8.0-r1.ebuild b/dev-libs/simde/simde-0.8.0-r1.ebuild
deleted file mode 100644
index 9591e89b2fec..000000000000
--- a/dev-libs/simde/simde-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson
-
-DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
-HOMEPAGE="https://simd-everywhere.github.io/blog/"
-SRC_URI="
- https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.7.6-musl.patch
- "${FILESDIR}"/${P}-xop.patch
-)
-
-src_configure() {
- # *FLAGS are only used for tests (nothing that is installed), and
- # upstream tests with specific *FLAGS and is otherwise flaky with
- # -march=native, -mno-*, and such -- unset to be spared headaches.
- unset {C,CPP,CXX,LD}FLAGS
-
- local emesonargs=(
- $(meson_use test tests)
- )
-
- meson_src_configure
-}
-
-src_test() {
- if use x86; then
- # https://github.com/simd-everywhere/simde/issues/867 (bug #926706)
- meson_src_test $(meson_src_test --list | grep -Ev '(dbsad|fpclass)')
- else
- meson_src_test
- fi
-}