summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-16 23:29:42 +0100
committerSam James <sam@gentoo.org>2022-09-17 00:25:26 +0100
commit3ad6503b57318429472a8a78973b8b3bdca4f7f2 (patch)
treeb5dbf982ca0edd6be76883ab11b779ae6f990ea2 /dev-libs
parentdev-libs/libksba: add 1.6.1 (diff)
downloadgentoo-3ad6503b57318429472a8a78973b8b3bdca4f7f2.tar.gz
gentoo-3ad6503b57318429472a8a78973b8b3bdca4f7f2.tar.bz2
gentoo-3ad6503b57318429472a8a78973b8b3bdca4f7f2.zip
dev-libs/popt: add 1.19
Closes: https://bugs.gentoo.org/663638 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/popt/Manifest1
-rw-r--r--dev-libs/popt/popt-1.19.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/popt/Manifest b/dev-libs/popt/Manifest
index 650e16e68029..d698ce53ffe1 100644
--- a/dev-libs/popt/Manifest
+++ b/dev-libs/popt/Manifest
@@ -1 +1,2 @@
DIST popt-1.18.tar.gz 580569 BLAKE2B c9c42eb12aa21764cde5e9b4a8b30125b547ae690b4d9d0d40b45bd3c1f7ae0b09d5086a588cf37e7bed71fe770ff840c0fd40ecf4ce5b7c1e874b938b6e0324 SHA512 86422e8762adda3d02d46c20ac74ffe389d4f991d552b6fea729f007345b6426cbeb71160284e2deaa2ce44ce754a9e6cf6ccbd64bff9bc2253df40cdc2f79a5
+DIST popt-1.19.tar.gz 596676 BLAKE2B 8f8965e2d339f0413e8d1da421ea7556526f39f089a822063d6fdc35b781a7c7ea84a91d6af3e25902c1f045f564ef956fc69cd4625e6cc008c9e3ca34923a9d SHA512 5d1b6a15337e4cd5991817c1957f97fc4ed98659870017c08f26f754e34add31d639d55ee77ca31f29bb631c0b53368c1893bd96cf76422d257f7997a11f6466
diff --git a/dev-libs/popt/popt-1.19.ebuild b/dev-libs/popt/popt-1.19.ebuild
new file mode 100644
index 000000000000..d936f9b6f309
--- /dev/null
+++ b/dev-libs/popt/popt-1.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="https://github.com/rpm-software-management/popt"
+SRC_URI="http://ftp.rpm.org/${PN}/releases/${PN}-1.x/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.8 )"
+
+src_prepare() {
+ default
+
+ #sed -i -e 's:lt-test1:test1:' tests/testit.sh || die
+ elibtoolize
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}