summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-01-19 19:31:32 -0500
committerAnthony G. Basile <blueness@gentoo.org>2021-01-19 19:31:32 -0500
commit14855cf5157e74a9d857dd159e402495eea0ffa1 (patch)
treea0754075b4b8584681195952a605163c627d31a3 /dev-libs/xapian
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.9 (diff)
downloadgentoo-14855cf5157e74a9d857dd159e402495eea0ffa1.tar.gz
gentoo-14855cf5157e74a9d857dd159e402495eea0ffa1.tar.bz2
gentoo-14855cf5157e74a9d857dd159e402495eea0ffa1.zip
dev-libs/xapian: version bump to 1.4.18
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.18.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index f557a0eaaf88..f3e48c4b944e 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -3,3 +3,4 @@ DIST xapian-core-1.4.14.tar.xz 2970624 BLAKE2B 5bfa5ab36ad4626fcc9a214427f88bdf5
DIST xapian-core-1.4.15.tar.xz 2988752 BLAKE2B d68d69cdc55c1b62a746620fc90f028819813bb98c0ad0cc130c399a4dd62231b920d24363b61e58d002f65a79a117598455779028de1b26b7a808367f5f2de4 SHA512 f28209acae12a42a345382668f7f7da7a2ce5a08362d0e2af63c9f94cb2adca95366499a7afa0bd9008fbfcca4fd1f2c9221e594fc2a2c740f5899e9f03ecad3
DIST xapian-core-1.4.16.tar.xz 3041132 BLAKE2B 2c009bcdec05542ceae9354e47e8ff9b971ec87d04caf8058711fd6952135620c353f2feabcd869313f55194409944bc7374ce69d626f948461963a7790c3953 SHA512 3d319ab672485e840019ee28b54b1c59bbd535c1802874f58593fb999681c19bff3e776dc19ab5d5bd97734bf01f1408f36ae49e21ca9706ca187db49f8a18a6
DIST xapian-core-1.4.17.tar.xz 2997700 BLAKE2B 882bc28c9a55731212a5c3ac6da3ad2082e3345cb473eb2c09b80fdd05e700bb31cff6c9a0524b27da015b14655c30548e92a457b48af43279bfd3564cf3c3fa SHA512 3eaf45d31eb9318e292fa052b32b1d9e1035651bdd3c366a0134f4b39d03d987083c19426a3d4b10f60078190fc3388f05b332cba958263bab1abf236c7a3ca7
+DIST xapian-core-1.4.18.tar.xz 2984508 BLAKE2B e5d680578e0a4605a8e99470921fba29cdd3d137d017608b8bf571951726055d2a1d49e9649829f0df92af3d27d0565f90baaca5a4eb5c67cb368f5d1e592d28 SHA512 ba6240054c0d2f92b9f1059aa934cdf35388ee7c7e05f4ef6f9856bdaed8ad821095a348ed9a892afdf18c3c0ad20e163028ad0ed3a9934bd69b861e814678ef
diff --git a/dev-libs/xapian/xapian-1.4.18.ebuild b/dev-libs/xapian/xapian-1.4.18.ebuild
new file mode 100644
index 000000000000..b33e8c6402c3
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.18.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="https://www.xapian.org/"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +inmemory +remote"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+ use remote || myconf="${myconf} --disable-backend-remote"
+
+ myconf="${myconf} --enable-backend-glass --enable-backend-chert --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_test() {
+ emake check VALGRIND=
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ rm -rf "${D}/usr/share/doc/xapian-core-${PV}" || die
+ fi
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ find "${D}" -name "*.la" -type f -delete || die
+}