summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-07-28 11:33:08 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-07-28 11:36:41 +0300
commit7c9ad187168f53f95ee2324769e48676505033f7 (patch)
tree0329070e6a09aa64f62a97e01a2d3a8121ad47da /dev-libs/xalan-c
parentdev-libs/xalan-c: fix building with gcc-15 (diff)
downloadgentoo-7c9ad187168f53f95ee2324769e48676505033f7.tar.gz
gentoo-7c9ad187168f53f95ee2324769e48676505033f7.tar.bz2
gentoo-7c9ad187168f53f95ee2324769e48676505033f7.zip
dev-libs/xalan-c: drop 9999
Pointless to keep, upstream is dead. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-libs/xalan-c')
-rw-r--r--dev-libs/xalan-c/xalan-c-9999.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-libs/xalan-c/xalan-c-9999.ebuild b/dev-libs/xalan-c/xalan-c-9999.ebuild
deleted file mode 100644
index 13753c18e646..000000000000
--- a/dev-libs/xalan-c/xalan-c-9999.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-MY_PN=${PN/-/_}
-DESCRIPTION="XSLT processor for transforming XML into HTML, text, or other XML types"
-HOMEPAGE="https://apache.github.io/xalan-c/"
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/apache/xalan-c.git"
-
- SLOT="0"
-else
- inherit verify-sig
- SRC_URI="
- https://dlcdn.apache.org/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz
- verify-sig? ( https://dlcdn.apache.org/xalan/xalan-c/sources/${MY_PN}-${PV}.tar.gz.asc )
- "
- VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/apache-xalan-c.asc
-
- SLOT="0/$(ver_cut 1-2)"
- KEYWORDS="~amd64 ~ppc ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
- BDEPEND="
- verify-sig? ( sec-keys/openpgp-keys-apache-xalan-c )
- "
-fi
-
-LICENSE="Apache-2.0"
-IUSE="doc"
-
-RDEPEND="
- dev-libs/icu:=
- dev-libs/xerces-c[icu]
-"
-DEPEND="${RDEPEND}"
-BDEPEND+="
- doc? ( app-text/doxygen[dot] )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.12-fix-lto.patch
- "${FILESDIR}"/${PN}-1.12-icu-75.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -Ddoxygen=$(usex doc)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use doc; then
- docinto examples
- dodoc -r samples/*/
- fi
-}