summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-05 01:07:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-05 01:12:00 +0100
commite2d46240c93461114eebe3a3e9b4a173d2d39927 (patch)
tree27bf425fd7214d3b4cc65817f3760919f1eb6bd4 /dev-libs/wayland
parentkde-apps/kpat: EAPI-7 bump (diff)
downloadgentoo-e2d46240c93461114eebe3a3e9b4a173d2d39927.tar.gz
gentoo-e2d46240c93461114eebe3a3e9b4a173d2d39927.tar.bz2
gentoo-e2d46240c93461114eebe3a3e9b4a173d2d39927.zip
dev-libs/wayland: EAPI-7 bump, switch to new EGIT_REPO_URI
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/wayland-9999.ebuild57
1 files changed, 27 insertions, 30 deletions
diff --git a/dev-libs/wayland/wayland-9999.ebuild b/dev-libs/wayland/wayland-9999.ebuild
index df8f72793cfe..7e909b198261 100644
--- a/dev-libs/wayland/wayland-9999.ebuild
+++ b/dev-libs/wayland/wayland-9999.ebuild
@@ -1,42 +1,41 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit autotools libtool multilib-minimal toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI=""
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
+ inherit git-r3
else
SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
+inherit autotools libtool multilib-minimal toolchain-funcs
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="https://wayland.freedesktop.org/"
LICENSE="MIT"
SLOT="0"
IUSE="doc static-libs"
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:=
- !<media-libs/mesa-18.1.1-r1"
-DEPEND="${RDEPEND}
+BDEPEND="
+ virtual/pkgconfig
doc? (
>=app-doc/doxygen-1.6[dot]
app-text/xmlto
>=media-gfx/graphviz-2.26.0
sys-apps/grep[pcre]
)
- virtual/pkgconfig"
+"
+DEPEND="
+ >=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=
+ >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<media-libs/mesa-18.1.1-r1
+"
src_prepare() {
default
@@ -44,16 +43,14 @@ src_prepare() {
}
multilib_src_configure() {
- local myconf
- if tc-is-cross-compiler ; then
- myconf+=' --with-host-scanner '
- fi
+ local myeconfargs=(
+ --disable-static
+ $(multilib_native_use_enable doc documentation)
+ $(multilib_native_enable dtd-validation)
+ )
+ tc-is-cross-compiler && myeconfargs+=( --with-host-scanner )
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- $(multilib_native_use_enable doc documentation) \
- $(multilib_native_enable dtd-validation) \
- ${myconf}
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {