summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-04-26 22:10:01 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-04-26 22:10:01 +0200
commite65f6fd2d962538ad354a48a3b0302a7b628a18d (patch)
tree28ece716d1098601bbfb5d41cb25d3e85e5cb8a0 /dev-libs/tinyxml
parentsys-apps/hdparm: Bump to version 9.61 (diff)
downloadgentoo-e65f6fd2d962538ad354a48a3b0302a7b628a18d.tar.gz
gentoo-e65f6fd2d962538ad354a48a3b0302a7b628a18d.tar.bz2
gentoo-e65f6fd2d962538ad354a48a3b0302a7b628a18d.zip
dev-libs/tinyxml: clean old version
Closes: https://bugs.gentoo.org/783705 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-libs/tinyxml')
-rw-r--r--dev-libs/tinyxml/tinyxml-2.6.2-r3.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-libs/tinyxml/tinyxml-2.6.2-r3.ebuild b/dev-libs/tinyxml/tinyxml-2.6.2-r3.ebuild
deleted file mode 100644
index 537f31101a28..000000000000
--- a/dev-libs/tinyxml/tinyxml-2.6.2-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit epatch flag-o-matic toolchain-funcs multilib versionator
-
-DESCRIPTION="Simple and small C++ XML parser"
-HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV//./_}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="debug doc static-libs +stl"
-
-DEPEND="doc? ( app-doc/doxygen )"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- local major_v=$(get_major_version)
- local minor_v=$(get_version_component_range 2-3)
-
- sed -e "s:@MAJOR_V@:$major_v:" \
- -e "s:@MINOR_V@:$minor_v:" \
- "${FILESDIR}"/Makefile-3 > Makefile || die
-
- epatch "${FILESDIR}"/${PN}-2.6.1-entity.patch
- epatch "${FILESDIR}"/${PN}.pc.patch
-
- use debug && append-cppflags -DDEBUG
- use stl && epatch "${FILESDIR}"/${P}-defineSTL.patch
-
- if use stl; then
- sed -e "s/Cflags: -I\${includedir}/Cflags: -I\${includedir} -DTIXML_USE_STL=YES/g" -i tinyxml.pc || die
- fi
-
- if ! use static-libs; then
- sed -e "/^all:/s/\$(name).a //" -i Makefile || die
- fi
-
- tc-export AR CXX RANLIB
-
- [[ ${CHOST} == *-darwin* ]] && export LIBDIR="${EPREFIX}"/usr/$(get_libdir)
- eapply_user
-}
-
-src_install() {
- dolib.so *$(get_libname)*
-
- insinto /usr/include
- doins *.h
-
- insinto /usr/share/pkgconfig
- doins tinyxml.pc
-
- dodoc {changes,readme}.txt
-
- use doc && dohtml -r docs/*
-}