summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/radlib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/radlib')
-rw-r--r--dev-libs/radlib/Manifest1
-rw-r--r--dev-libs/radlib/files/radlib-2.12.0-build.patch128
-rw-r--r--dev-libs/radlib/metadata.xml10
-rw-r--r--dev-libs/radlib/radlib-2.12.0-r1.ebuild41
4 files changed, 180 insertions, 0 deletions
diff --git a/dev-libs/radlib/Manifest b/dev-libs/radlib/Manifest
new file mode 100644
index 000000000000..688545f82f47
--- /dev/null
+++ b/dev-libs/radlib/Manifest
@@ -0,0 +1 @@
+DIST radlib-2.12.0.tar.gz 521798 SHA256 82b98bb5e08a500dea1e4252843b9c772fa1fb67ac8ab89ed64abdd5e22eca66 SHA512 be86fe899f4a3ab4be57f339682c4899a958b55b207f4425accf7f8b0badf0b68b84f3eeeb50ce67bf3459ac005297dfd23dd8a0f34d58d4f4584319ea752cc5 WHIRLPOOL 4d46b66403b1853408e783a2969f303033411cc9dfef8ca7839182625d8389244c716a10683b87e08d31285fcc2b88ad9f14d087384ead3c6e0b456d69dab203
diff --git a/dev-libs/radlib/files/radlib-2.12.0-build.patch b/dev-libs/radlib/files/radlib-2.12.0-build.patch
new file mode 100644
index 000000000000..4f4ce750ad35
--- /dev/null
+++ b/dev-libs/radlib/files/radlib-2.12.0-build.patch
@@ -0,0 +1,128 @@
+Index: radlib-2.12.0/debug/Makefile.am
+===================================================================
+--- radlib-2.12.0.orig/debug/Makefile.am
++++ radlib-2.12.0/debug/Makefile.am
+@@ -13,32 +13,4 @@ raddebug_SOURCES = \
+ $(top_srcdir)/debug/raddebug.c
+
+ # define libraries
+-raddebug_LDADD = -lrad -lpthread
+-
+-if MYSQL
+-raddebug_LDADD += -lmysqlclient
+-else
+-if PGRESQL
+-raddebug_LDADD += -lpq
+-endif
+-endif
+-if SQLITE
+-raddebug_LDADD += -lsqlite3
+-endif
+-
+-# define library directories
+-raddebug_LDFLAGS = -L../src/.libs -L$(prefix)/lib -L/usr/lib
+-INCLUDES += -I$(prefix)/include -I/usr/include
+-
+-if MYSQL
+-raddebug_LDFLAGS += -L$(prefix)/lib64/mysql -L$(prefix)/lib/mysql -L/usr/lib64/mysql -L/usr/lib/mysql
+-else
+-if PGRESQL
+-raddebug_LDFLAGS += -L$(prefix)/pgsql/lib
+-INCLUDES += -I$(prefix)/pgsql/include
+-endif
+-endif
+-
+-if CROSSCOMPILE
+-raddebug_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
+-endif
++raddebug_LDADD = ../src/librad.la
+Index: radlib-2.12.0/msgRouter/Makefile.am
+===================================================================
+--- radlib-2.12.0.orig/msgRouter/Makefile.am
++++ radlib-2.12.0/msgRouter/Makefile.am
+@@ -13,32 +13,4 @@ radmrouted_SOURCES = \
+ $(top_srcdir)/msgRouter/msgRouter.c
+
+ # define libraries
+-radmrouted_LDADD = -lrad -lpthread
+-
+-if MYSQL
+-radmrouted_LDADD += -lmysqlclient
+-else
+-if PGRESQL
+-radmrouted_LDADD += -lpq
+-endif
+-endif
+-if SQLITE
+-radmrouted_LDADD += -lsqlite3
+-endif
+-
+-# define library directories
+-radmrouted_LDFLAGS = -L../src/.libs -L$(prefix)/lib -L/usr/lib
+-INCLUDES += -I$(prefix)/include -I/usr/include
+-
+-if MYSQL
+-radmrouted_LDFLAGS += -L$(prefix)/lib64/mysql -L$(prefix)/lib/mysql -L/usr/lib64/mysql -L/usr/lib/mysql
+-else
+-if PGRESQL
+-radmrouted_LDFLAGS += -L$(prefix)/lib -L$(prefix)/pgsql/lib
+-INCLUDES += -I$(prefix)/pgsql/include
+-endif
+-endif
+-
+-if CROSSCOMPILE
+-radmrouted_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
+-endif
++radmrouted_LDADD = ../src/librad.la
+Index: radlib-2.12.0/src/Makefile.am
+===================================================================
+--- radlib-2.12.0.orig/src/Makefile.am
++++ radlib-2.12.0/src/Makefile.am
+@@ -12,6 +12,9 @@ SUBDIRS =
+ #define the library to be built
+ lib_LTLIBRARIES = librad.la
+
++librad_la_LDFLAGS =
++librad_la_LIBADD = -lpthread
++
+ if MYSQL
+ MY_INCLUDES = \
+ -I$(prefix)/include/mysql \
+@@ -21,32 +24,30 @@ MY_SOURCES = \
+ $(top_srcdir)/src/raddatabase.c
+ MYSQL_HDRS = \
+ $(top_srcdir)/h/raddatabase.h
++librad_la_LDFLAGS += -L$(prefix)/lib64/mysql -L$(prefix)/lib/mysql -L/usr/lib64/mysql -L/usr/lib/mysql
++librad_la_LIBADD += -lmysqlclient
+ endif
+ if PGRESQL
+-PG_INCLUDES = \
+- -I$(prefix)/include \
+- -I/usr/include
+ PG_SOURCES = \
+ $(top_srcdir)/database/postgresql/pg_database.c \
+ $(top_srcdir)/src/raddatabase.c
+ PGSQL_HDRS = \
+ $(top_srcdir)/h/raddatabase.h \
+ $(top_srcdir)/database/postgresql/_pg-types.h
++librad_la_LDFLAGS += -L$(prefix)/lib -L$(prefix)/pgsql/lib
++librad_la_LIBADD += -lpq
+ endif
+ if SQLITE
+-SQ_INCLUDES = \
+- -I$(prefix)/include \
+- -I/usr/include
+ SQ_SOURCES = \
+ $(top_srcdir)/src/radsqlite.c
+ SQLITE_HDRS = \
+ $(top_srcdir)/h/radsqlite.h
++librad_la_LIBADD += -lsqlite3
+ endif
+
+ # define include directories
+ INCLUDES = \
+ -I$(top_srcdir)/h \
+- -I$(prefix)/include \
+ -D_GNU_SOURCE \
+ $(MY_INCLUDES) \
+ $(PG_INCLUDES) \
diff --git a/dev-libs/radlib/metadata.xml b/dev-libs/radlib/metadata.xml
new file mode 100644
index 000000000000..4a551dc923d3
--- /dev/null
+++ b/dev-libs/radlib/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">radlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/radlib/radlib-2.12.0-r1.ebuild b/dev-libs/radlib/radlib-2.12.0-r1.ebuild
new file mode 100644
index 000000000000..d5f7a87a83bc
--- /dev/null
+++ b/dev-libs/radlib/radlib-2.12.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils autotools
+
+DESCRIPTION="Rapid Application Development Library"
+HOMEPAGE="http://www.radlib.teel.ws/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2"
+
+SLOT="0"
+IUSE="mysql postgres sqlite static-libs"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT_USE="^^ ( mysql postgres )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mysql)
+ $(use_enable postgres pgresql)
+ $(use_enable sqlite)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() { :; }