summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-25 08:53:14 +0000
committerSam James <sam@gentoo.org>2023-11-25 08:53:14 +0000
commit85aa0c68d749c9352a7291f6a2152e89e43db5d1 (patch)
tree70a3ab6480af5bf732607190ed5ed133a5bc5459 /dev-libs/pocl
parentdev-python/virtualenv: Stabilize 20.24.7 ALLARCHES, #918479 (diff)
downloadgentoo-85aa0c68d749c9352a7291f6a2152e89e43db5d1.tar.gz
gentoo-85aa0c68d749c9352a7291f6a2152e89e43db5d1.tar.bz2
gentoo-85aa0c68d749c9352a7291f6a2152e89e43db5d1.zip
dev-libs/pocl: drop 3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/pocl')
-rw-r--r--dev-libs/pocl/Manifest1
-rw-r--r--dev-libs/pocl/files/pocl-3.1-c++11.patch23
-rw-r--r--dev-libs/pocl/files/pocl-3.1-nodebug.patch29
-rw-r--r--dev-libs/pocl/pocl-3.1.ebuild126
4 files changed, 0 insertions, 179 deletions
diff --git a/dev-libs/pocl/Manifest b/dev-libs/pocl/Manifest
index 71518dab3615..b2eb19f5fd11 100644
--- a/dev-libs/pocl/Manifest
+++ b/dev-libs/pocl/Manifest
@@ -1,2 +1 @@
-DIST pocl-3.1.tar.gz 1928607 BLAKE2B 7044a96e361426408fabd973987a0d6956693e3c9095769ee94d7dac47a8841d7489933e94acd22451a1c8a2ca83cb8e6948aebe899b23a8a6080ef1b7b37e9c SHA512 40d17e81d715f6897aa1d97fd02834d45227d9d0bd4c70e76d727f9ad4df675c25b7158a862e20e63810182fdad82a3cb1e454668c3a6422a977e59c8325fa0c
DIST pocl-4.0.tar.gz 2140919 BLAKE2B 1e9dd4de4824dd4a9e2b0d053d1786062c135d3bf7ca99dc884657b89c651fca6c0f3dedb568439802a58b0bfabc10939ca344b0110ae5fdb31be06f596d2a48 SHA512 3835a9e8fc8562d50a91a11b807cf87a096891f5c27675127b66412eacff2e541b6143b49b4155f43a09f4e53faa062ec20f3b20badeca206ece9f45ad50f26a
diff --git a/dev-libs/pocl/files/pocl-3.1-c++11.patch b/dev-libs/pocl/files/pocl-3.1-c++11.patch
deleted file mode 100644
index e676979f2e95..000000000000
--- a/dev-libs/pocl/files/pocl-3.1-c++11.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://bugs.gentoo.org/903968
-https://github.com/pocl/pocl/issues/1200
-https://github.com/pocl/pocl/commit/b5a097e5e55922561f738eedbde050b0fec2e480
-
-From b5a097e5e55922561f738eedbde050b0fec2e480 Mon Sep 17 00:00:00 2001
-From: Topi Leppanen <topi.leppanen@tuni.fi>
-Date: Thu, 13 Apr 2023 11:14:23 +0300
-Subject: [PATCH] Don't use make_unique in countred example
-
-This is because of C++11 compatibility reasons.
-Fixes #1200.
---- a/examples/accel/OpenCLcontext.cpp
-+++ b/examples/accel/OpenCLcontext.cpp
-@@ -189,7 +189,8 @@ bool OpenCL_Manager::processCameraFrame(unsigned char* input, unsigned long *out
- return isValid;
- }
-
--OpenCL_Manager::OpenCL_Manager() : Context{std::make_unique<OpenCL_Context>()} {}
-+OpenCL_Manager::OpenCL_Manager()
-+ : Context{std::unique_ptr<OpenCL_Context>(new OpenCL_Context())} {}
- OpenCL_Manager::~OpenCL_Manager() {}
-
-
diff --git a/dev-libs/pocl/files/pocl-3.1-nodebug.patch b/dev-libs/pocl/files/pocl-3.1-nodebug.patch
deleted file mode 100644
index ea1085dc4a49..000000000000
--- a/dev-libs/pocl/files/pocl-3.1-nodebug.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://github.com/pocl/pocl/commit/a13cb332d6678d4556d7319b284b77c371c4b91e
-
-commit a13cb332d6678d4556d7319b284b77c371c4b91e
-Author: Martin Kletzander <nert.pinx@gmail.com>
-Date: Tue Jan 17 09:04:41 2023 +0100
-
- Add stub macro POCL_MSG_PRINT_ALMAIF_MMAP without POCL_DEBUG_MESSAGES
-
- Without this the build fails with the following error when built without
- POCL_DEBUG_MESSAGES:
-
- ../lib/CL/devices/almaif/MMAPRegion.cc: In constructor ‘MMAPRegion::MMAPRegion(size_t, size_t, int)’:
- ../lib/CL/devices/almaif/MMAPRegion.cc:43:3: error: ‘POCL_MSG_PRINT_ALMAIF_MMAP’ was not declared in this scope; did you mean ‘POCL_MSG_PRINT_ALMAIF2’?
- 43 | POCL_MSG_PRINT_ALMAIF_MMAP(
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~
- | POCL_MSG_PRINT_ALMAIF2
-
- and about 10 more.
-
---- a/lib/CL/pocl_debug.h
-+++ b/lib/CL/pocl_debug.h
-@@ -284,6 +284,7 @@ POCL_EXPORT
-
- #define POCL_MSG_PRINT_ALMAIF2(...) do {} while (0)
- #define POCL_MSG_PRINT_ALMAIF(...) do {} while (0)
-+ #define POCL_MSG_PRINT_ALMAIF_MMAP(...) do {} while (0)
- #define POCL_MSG_PRINT_PROXY2(...) do {} while (0)
- #define POCL_MSG_PRINT_PROXY(...) do {} while (0)
- #define POCL_MSG_PRINT_VULKAN2(...) do {} while (0)
diff --git a/dev-libs/pocl/pocl-3.1.ebuild b/dev-libs/pocl/pocl-3.1.ebuild
deleted file mode 100644
index ff61446e2a20..000000000000
--- a/dev-libs/pocl/pocl-3.1.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_MAX_SLOT=15
-
-inherit cmake llvm
-
-DESCRIPTION="Portable Computing Language (an implementation of OpenCL)"
-HOMEPAGE="http://portablecl.org https://github.com/pocl/pocl"
-SRC_URI="https://github.com/pocl/pocl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc64"
-# TODO: hsa tce
-IUSE="accel +conformance cuda debug examples float-conversion hardening +hwloc memmanager lto test"
-# Tests not yet passing, fragile in Portage environment(?)
-RESTRICT="!test? ( test ) test"
-
-# TODO: add dependencies for cuda
-# Note: No := on LLVM because it pulls in Clang
-# see llvm.eclass for why
-CLANG_DEPS="
- !cuda? ( <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):= )
- cuda? ( <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=[llvm_targets_NVPTX] )
-"
-RDEPEND="
- dev-libs/libltdl
- <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):*
- virtual/opencl
-
- ${CLANG_DEPS}
- debug? ( dev-util/lttng-ust:= )
- hwloc? ( sys-apps/hwloc:=[cuda?] )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${CLANG_DEPS}
- virtual/pkgconfig
-"
-
-llvm_check_deps() {
- local usedep=$(usex cuda "[llvm_targets_NVPTX]" '')
-
- # Clang is used at both build time (executed) and runtime
- has_version -r "sys-devel/llvm:${LLVM_SLOT}${usedep}" && \
- has_version -r "sys-devel/clang:${LLVM_SLOT}${usedep}" && \
- has_version -b "sys-devel/clang:${LLVM_SLOT}${usedep}"
-}
-
-PATCHES=(
- "${FILESDIR}"/${P}-nodebug.patch
- "${FILESDIR}"/${P}-c++11.patch
-)
-
-pkg_setup() {
- llvm_pkg_setup
-}
-
-src_configure() {
- local host_cpu_variants="generic"
-
- if use amd64 ; then
- # Use pocl's curated list of CPU variants which should contain a good match for any given amd64 CPU
- host_cpu_variants="distro"
- elif use ppc64 ; then
- # A selection of architectures in which new Altivec / VSX features were added
- # This attempts to recreate the amd64 "distro" option for ppc64
- # See discussion in bug #831859
- host_cpu_variants="pwr10;pwr9;pwr8;pwr7;pwr6;g5;a2;generic"
- fi
-
- local mycmakeargs=(
- -DENABLE_HSA=OFF
-
- -DENABLE_ICD=ON
- -DPOCL_ICD_ABSOLUTE_PATH=ON
- -DPOCL_INSTALL_PUBLIC_LIBDIR="${EPREFIX}/usr/$(get_libdir)/OpenCL/vendors/pocl"
-
- -DENABLE_IPO=$(usex lto)
-
- -DENABLE_POCL_BUILDING=ON
- -DKERNELLIB_HOST_CPU_VARIANTS="${host_cpu_variants}"
-
- -DSTATIC_LLVM=OFF
- -DWITH_LLVM_CONFIG=$(get_llvm_prefix -d "${LLVM_MAX_SLOT}")/bin/llvm-config
-
- -DENABLE_ALMAIF_DEVICE=$(usex accel)
- -DENABLE_CONFORMANCE=$(usex conformance)
- -DENABLE_CUDA=$(usex cuda)
- -DENABLE_HWLOC=$(usex hwloc)
- -DENABLE_POCL_FLOAT_CONVERSION=$(usex float-conversion)
- -DHARDENING_ENABLE=$(usex hardening)
- -DPOCL_DEBUG_MESSAGES=$(usex debug)
- -DUSE_POCL_MEMMANAGER=$(usex memmanager)
- -DENABLE_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_test() {
- export POCL_BUILDING=1
- export POCL_DEVICES=basic
- export CTEST_OUTPUT_ON_FAILURE=1
- export TEST_VERBOSE=1
-
- # Referenced https://github.com/pocl/pocl/blob/master/.drone.yml
- # But couldn't seem to get tests working yet
- cmake_src_test
-}
-
-src_install() {
- cmake_src_install
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${P}/examples
- fi
-}