summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-05-31 10:06:09 +0200
committerDavid Seifert <soap@gentoo.org>2023-05-31 10:06:09 +0200
commitdbe09ca8fe77d867503ceb579ed64198624f5214 (patch)
treee3a849021be66b8a1a08bbb908878ea7e75185a7 /dev-libs/opensc
parentdev-libs/opensc: add 9999 (diff)
downloadgentoo-dbe09ca8fe77d867503ceb579ed64198624f5214.tar.gz
gentoo-dbe09ca8fe77d867503ceb579ed64198624f5214.tar.bz2
gentoo-dbe09ca8fe77d867503ceb579ed64198624f5214.zip
dev-libs/opensc: sync with 9999 ebuild
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/opensc')
-rw-r--r--dev-libs/opensc/opensc-0.23.0.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-libs/opensc/opensc-0.23.0.ebuild b/dev-libs/opensc/opensc-0.23.0.ebuild
index b46faccba7b9..5e6d2db59ebf 100644
--- a/dev-libs/opensc/opensc-0.23.0.ebuild
+++ b/dev-libs/opensc/opensc-0.23.0.ebuild
@@ -7,11 +7,17 @@ inherit bash-completion-r1 libtool
DESCRIPTION="Libraries and applications to access smartcards"
HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
-SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/OpenSC/OpenSC.git"
+else
+ SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 ppc64 x86"
+fi
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 ppc64 x86"
IUSE="ctapi doc openct notify pace +pcsc-lite readline secure-messaging ssl test zlib"
RESTRICT="!test? ( test )"
@@ -36,7 +42,12 @@ REQUIRED_USE="
src_prepare() {
default
- elibtoolize
+
+ if [[ ${PV} == *9999 ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_configure() {